diff mbox series

[bug#69640] gnu: Add go-github-com-klauspost-pgzip.

Message ID 87h6hgizj1.fsf@troyfigiel.com
State New
Headers show
Series [bug#69640] gnu: Add go-github-com-klauspost-pgzip. | expand

Commit Message

Troy Figiel March 8, 2024, 2:10 p.m. UTC
* gnu/packages/golang-compression.scm (go-github-com-klauspost-pgzip): New variable.
---
 gnu/packages/golang-compression.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)


base-commit: d79c88e8809d2079452fd276bf4d17eb16636ff9

Comments

Sharlatan Hellseher March 17, 2024, 12:17 a.m. UTC | #1
Hi,

Pushed as d7e6c3cae0762d6a299162f2d7d8c44ca1390dd7 to master.

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/golang-compression.scm b/gnu/packages/golang-compression.scm
index b999c063ee..504491e8e0 100644
--- a/gnu/packages/golang-compression.scm
+++ b/gnu/packages/golang-compression.scm
@@ -140,6 +140,33 @@  (define-public go-github-com-klauspost-compress
     (description "@code{compress} provides various compression algorithms.")
     (license license:bsd-3)))
 
+(define-public go-github-com-klauspost-pgzip
+  (package
+    (name "go-github-com-klauspost-pgzip")
+    (version "1.2.6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/klauspost/pgzip")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1j29wr6nd9ncdbkjphyziv0h8p5s2mj222cgcfqxmzjnfn7623d8"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/klauspost/pgzip"))
+    (propagated-inputs (list go-github-com-klauspost-compress))
+    (home-page "https://github.com/klauspost/pgzip")
+    (synopsis "Parallel (de)compression of gzip files in Go")
+    (description
+     "This package implements parallel gzip compression and decompression in
+Golang and is fully compatible with @code{compress/gzip} from the standard
+library.  This is beneficial for large amounts of data, say more than 1MB at a
+time, as otherwise the internal gzip library will likely be faster.")
+    (license (list license:bsd-3 license:expat))))
+
 (define-public go-github-com-nwaples-rardecode-v2
   (package
     (name "go-github-com-nwaples-rardecode-v2")