diff mbox series

[bug#69862] update mu to 1.12.2

Message ID 87h6h4epb4.fsf@lambda-y.net
State New
Headers show
Series [bug#69862] update mu to 1.12.2 | expand

Commit Message

Benjamin Slade March 17, 2024, 5:33 p.m. UTC
--

'(Dr Benjamin Slade (he/him)
     (website . <https://lambda-y.net>)     
     `(pgp_fp: ,(B20E 444C FA80 B5F8 15FA  4AD8 6FBF CD68 3B05 2B84))
       "sent by mu4e 1.12.2 in Emacs 30.0.50 with org-msg on GNU Guix (Linux)")

Comments

Ludovic Courtès March 22, 2024, 10:42 a.m. UTC | #1
Hi,

Benjamin Slade <slade@lambda-y.net> skribis:

>>From eeaea275fab5141dad07ed01614018a5eb8e0511 Mon Sep 17 00:00:00 2001
> From: Benjamin Slade <slade@lambda-y.net>
> Date: Sun, 17 Mar 2024 10:33:02 -0500
> Subject: [PATCH] update mu to 1.12.2
>

I added a commit log that follows our conventions and applied it.

>            (add-after 'unpack 'patch-bin-references
>              (lambda _
>                (substitute* '("guile/tests/test-mu-guile.cc"
> -                             "mu/tests/test-mu-cmd.cc"
> -                             "mu/tests/test-mu-cmd-cfind.cc"
>                               "mu/tests/test-mu-query.cc")
>                  (("/bin/sh") (which "sh")))
>                (substitute* '("lib/tests/bench-indexer.cc"
>                               "lib/utils/mu-test-utils.cc")
> -                (("/bin/rm") (which "rm")))))
> +                (("/bin/rm") (which "rm")))
> +              (substitute* '("lib/mu-maildir.cc")
> +                (("/bin/mv") (which "mv")))))

This won’t do the right thing when cross-compiling.  To fix it, it
should be changed to things like:

  (search-input-file inputs "/bin/mv")

The problem predates this patch of course so it’s not a blocker, but
something to look at going forward.

Thanks,
Ludo’.
diff mbox series

Patch

From eeaea275fab5141dad07ed01614018a5eb8e0511 Mon Sep 17 00:00:00 2001
From: Benjamin Slade <slade@lambda-y.net>
Date: Sun, 17 Mar 2024 10:33:02 -0500
Subject: [PATCH] update mu to 1.12.2

---
 gnu/packages/mail.scm | 13 +++++++------
 1 file changed, 7 insertions(+), 6 deletions(-)

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 9688c36..7ff5d23 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -54,6 +54,7 @@ 
 ;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
 ;;; Copyright © 2023 Arjan Adriaanse <arjan@adriaan.se>
 ;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
+;;; Copyright © 2024 Benjamin Slade <slade@lambda-y.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1208,14 +1209,14 @@  (define-public emacs-mew
 (define-public mu
   (package
     (name "mu")
-    (version "1.10.8")
+    (version "1.12.2")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/djcb/mu/releases/download/v"
                            version "/mu-" version ".tar.xz"))
        (sha256
-        (base32 "129m6rz8vbd7370c3h3ma66bxqdkm6wsdix5qkmv1vm7sanxh4bb"))))
+        (base32 "065nqrsz5bpvhniaacfq67fh78m5pm96svingdviw2hj1y21s6kv"))))
     (build-system meson-build-system)
     (native-inputs
      (list pkg-config
@@ -1223,7 +1224,7 @@  (define-public mu
            gnupg                        ; for tests
            texinfo))
     (inputs
-     (list glib gmime guile-3.0 xapian))
+     (list glib gmime guile-3.0 xapian readline python))
     (arguments
      (list
       #:modules '((guix build meson-build-system)
@@ -1238,13 +1239,13 @@  (define-public mu
           (add-after 'unpack 'patch-bin-references
             (lambda _
               (substitute* '("guile/tests/test-mu-guile.cc"
-                             "mu/tests/test-mu-cmd.cc"
-                             "mu/tests/test-mu-cmd-cfind.cc"
                              "mu/tests/test-mu-query.cc")
                 (("/bin/sh") (which "sh")))
               (substitute* '("lib/tests/bench-indexer.cc"
                              "lib/utils/mu-test-utils.cc")
-                (("/bin/rm") (which "rm")))))
+                (("/bin/rm") (which "rm")))
+              (substitute* '("lib/mu-maildir.cc")
+                (("/bin/mv") (which "mv")))))
           (add-after 'install 'fix-ffi
             (lambda _
               (substitute* (find-files #$output "mu.scm")
-- 
2.41.0