[bug#78401] gnu: mupdf: Update to 1.26.0., [PATCH] gnu: mupdf: Update to 1.26.0., [PATCH] gnu: mupdf: Modify #:make-flags

Message ID 87h61jyvpe.fsf@subvertising.org
State New
Headers
Series [bug#78401] gnu: mupdf: Update to 1.26.0., [PATCH] gnu: mupdf: Update to 1.26.0., [PATCH] gnu: mupdf: Modify #:make-flags |

Commit Message

Divya Ranjan May 17, 2025, 5:48 p.m. UTC
  Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> Hi Divya,
>
> Divya Ranjan <divya@subvertising.org> writes:
>
> [...]
>
>>>> * gnu/packages/pdf.scm (mupdf): Update to 1.26.0.
>>>
>>> Various changes done here are not listed in the change log.  Please
>>> consult other commits for examples or (info "(standards) Style of Change
>>> Logs").
>>
>> Please find the updated patch with the indentation and commit message fixed.
>
> Thanks for you efforts, but the change log is still missing many
> entries.  It should list for example every input added or remove, every
> configure flag added or removed, every phase added or removed, etc.  For
> some examples, you can install the 'standards' package and consult (info
> "(standards) Style of Change Logs"), or simply read examples through
> 'git log'.
>
> While the whitespace is fixed in v2, it seems you ran the package
> through 'guix style', which sadly is not always optimal and adds noise
> to the diff.  Could you please keep this commit to just modify what's
> needed?

Hello Maxim,

Apologies, indeed I had used guix style since I considered that it’d be appropriate. I’ve restricted the patch to now only include the necessary changes.
Also find the patch for mupdf-1.24, without which several packages break (as suggested by the QA).
  

Patch

From 27443887660f0179610a37c5ca8137021a8afef2 Mon Sep 17 00:00:00 2001
Message-ID: <27443887660f0179610a37c5ca8137021a8afef2.1747504078.git.divya@subvertising.org>
From: Divya Ranjan <divya@subvertising.org>
Date: Sat, 17 May 2025 17:47:04 +0000
Subject: [PATCH] * gnu: mupdf-1.24: Modify #:make-flags

[arguments]: Disable SONAME

Change-Id: I7557a5d8c9638acfc40abd79a78c196eb30f6baa
---
 gnu/packages/pdf.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 017609b338..f716da4d74 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -969,7 +969,14 @@  (define-public mupdf-1.24 ; Needed for sioyek
               (for-each delete-file-recursively
                         (lset-difference string=?
                                          (scandir ".")
-                                         (cons* "." ".." keep))))))))))
+                                         (cons* "." ".." keep))))))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments mupdf)
+       ((#:make-flags flags)
+        #~(append (filter (lambda (flag)
+                            (not (string-prefix? "USE_SONAME=" flag)))
+                          #$flags)
+                  (list "USE_SONAME=no")))))))
 
 
 (define-public qpdf

base-commit: efac01f19b65d7d77a98bbfd57fe2073fb13064a
prerequisite-patch-id: bc8c7d6415d46bb7e474e6c50bf33339c41defd3
-- 
2.49.0