bug#33987: [PATCH] gnu: Add ghc-tldr.

Message ID 87fttry7qa.fsf@gnu.org
State Accepted
Headers show
Series bug#33987: [PATCH] gnu: Add ghc-tldr. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Ludovic Courtès Jan. 17, 2019, 9:05 a.m. UTC
Hi,

Gabriel Hondet <gabrielhondet@gmail.com> skribis:

> It builds correctly for me on 38f18309e1f13b1df9add9dafcbc634f0e15004c
> and on 64d25f0be214795050b058047133d11f1d5dcbf5 as well, so I don't
> know... But interestingly, I have already seen this error, with
> text-1.2.3.0 (when trying to build ghc-conduit-extra for instance).
>
> On the other hand I have removed two dependencies that were specified by
> the ~guix import~ command but seemed useless, as it works without them
> (ghc-text and ghc-ansi-terminal).
>
> * gnu/packages/haskell.scm (ghc-tldr): New variable.

Well, it works for me this time.

Applied with the minor changes below.

The ‘tldr’ command looks pretty handy!

Thanks,
Ludo’.

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9db23be01e..b40a5d05da 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11389,12 +11389,12 @@  avoid the problem of partial intermediate files.")
     (native-inputs
      `(("ghc-tasty" ,ghc-tasty)
        ("ghc-tasty-golden" ,ghc-tasty-golden)))
-    (home-page
-     "https://github.com/psibi/tldr-hs#readme")
+    (home-page "https://github.com/psibi/tldr-hs#readme")
     (synopsis "Haskell tldr client")
-    (description "Haskell client allowing the user to update and view
-@code{tldr} pages from a shell.  The @code{tldr} pages are a community effort
-to simplify the man pages with practical examples.")
+    (description "This package provides the @command{tldr} command and a
+Haskell client library allowing users to update and view @code{tldr} pages
+from a shell.  The @code{tldr} pages are a community effort to simplify the
+man pages with practical examples.")
     (license license:bsd-3)))
 
 ;;; haskell.scm ends here