[bug#34120] gnu: Add cqfd.

Message ID 87fttq3514.fsf@gmail.com
State Accepted
Headers show
Series [bug#34120] gnu: Add cqfd. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Maxim Cournoyer Jan. 18, 2019, 5:31 a.m. UTC
Hello!

Now that we have a Docker package (thanks to Danny!), this adds cqfd, a
small tool to keep track of a Docker base build environment
configuration/build commands.

Thanks :-)

Maxim

Comments

Ludovic Courtès Feb. 5, 2019, 11:11 a.m. UTC | #1
Hello!

Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

> From c94101e5126f34c613b6a6a3daca1373a90b0882 Mon Sep 17 00:00:00 2001
> From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
> Date: Thu, 17 Jan 2019 22:03:47 -0500
> Subject: [PATCH] gnu: Add cqfd.
>
> * gnu/packages/docker.scm (cqfd): New variable.

LGTM, thanks!

BTW, for a simple package like this, you can apply the simple-patch rule
that ‘HACKING’ describes and push quickly if nobody comments.

Thanks,
Ludo’.
Maxim Cournoyer Feb. 5, 2019, 2:37 p.m. UTC | #2
Hello!

Ludovic Courtès <ludo@gnu.org> writes:

> Hello!
>
> Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:
>
>> From c94101e5126f34c613b6a6a3daca1373a90b0882 Mon Sep 17 00:00:00 2001
>> From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
>> Date: Thu, 17 Jan 2019 22:03:47 -0500
>> Subject: [PATCH] gnu: Add cqfd.
>>
>> * gnu/packages/docker.scm (cqfd): New variable.
>
> LGTM, thanks!

> BTW, for a simple package like this, you can apply the simple-patch rule
> that ‘HACKING’ describes and push quickly if nobody comments.

I added a copyright attribution line for myself and pushed to master
with commit 975a953bf. I will commit directly any future trivial
packages, thanks for reminding me about that rule!

Thanks! :-)

Maxim

Patch

From c94101e5126f34c613b6a6a3daca1373a90b0882 Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Thu, 17 Jan 2019 22:03:47 -0500
Subject: [PATCH] gnu: Add cqfd.

* gnu/packages/docker.scm (cqfd): New variable.
---
 gnu/packages/docker.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 23695a0c0..425244a48 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -528,3 +528,41 @@  provisioning etc.")
     (description "This package provides a command line interface to Docker.")
     (home-page "http://www.docker.com/")
     (license license:asl2.0)))
+
+(define-public cqfd
+  (package
+    (name "cqfd")
+    (version "5.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/savoirfairelinux/cqfd.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1z4v16lbpbwd5ykawizdclpryp2k006lbk2mv427a4b3nvcd9wik"))))
+    (build-system gnu-build-system)
+    (arguments
+     ;; The test suite requires a docker daemon and connectivity.
+     `(#:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (delete 'build)
+         (replace 'install
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               ;; Fix the directory of the bash completion.
+               (substitute* "Makefile"
+                 (("completionsdir=.*$")
+                  (string-append "completionsdir=" out
+                                 "/etc/bash_completion.d; \\\n")))
+               (invoke "make" "install"
+                       (string-append "PREFIX=" out))))))))
+    (home-page "https://github.com/savoirfairelinux/cqfd")
+    (synopsis "Convenience wrapper for Docker")
+    (description "cqfd is a Bash script that provides a quick and convenient
+way to run commands in the ecurrent directory, but within a Docker container
+defined in a per-project configuration file.")
+    (license license:gpl3+)))
-- 
2.20.1