From 62ad3f8a8a62fddc4e83cdbc43d2701dcd476224 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Thu, 5 Dec 2019 13:51:14 -0600
Subject: [PATCH 3/3] gnu: emacs-telega: Install telega-data to site-lisp.
* gnu/packages/emacs-xyz.scm (emacs-telega)[arguments]: This commit revises a
previous patch and gives the source etc/ directory a unique installation pth
in the site-lisp directory stucture.
Co-authored-by: Leo Prikler <leo.prikler@student.tugraz.at>
---
gnu/packages/emacs-xyz.scm | 26 +++++++++++++++++++++++---
1 file changed, 23 insertions(+), 3 deletions(-)
@@ -19989,6 +19989,13 @@ fish-completion. It can be used in both Eshell and M-x shell.")
(("python3 run_tests.py")
""))
#t))
+ ;; Modify telega-util to reflect unique dir name in
+ ;; `telega-install-data' phase.
+ (add-after 'unpack 'telega-data-patch
+ (lambda _
+ (substitute* "telega-util.el"
+ (("etc/") "telega-data/"))
+ #t))
;; The telega test suite checks for a version of Emacs
;; compiled with imagemagick and svg support. Since we
;; are using `emacs-minimal`, this step will fail.
@@ -20019,11 +20026,24 @@ fish-completion. It can be used in both Eshell and M-x shell.")
;; Build emacs-side using `emacs-build-system'
(add-after 'compress-documentation 'emacs-add-source-to-load-path
(assoc-ref emacs:%standard-phases 'add-source-to-load-path))
- (add-after 'emacs-set-emacs-load-path 'emacs-install
+ (add-after 'emacs-add-source-to-load-path 'emacs-install
(assoc-ref emacs:%standard-phases 'install))
- (add-after 'emacs-install 'emacs-build
+ ;; This step adds subdir /etc to the site-lisp dir and
+ ;; gives it a unique name which is needed for images,
+ ;; notification sounds, and various alists.
+ ;; TODO: Replace with `#:include' method used by
+ ;; emacs-build-system.
+ (add-after 'emacs-install 'telega-install-data
+ (lambda* (#:key outputs #:allow-other-keys)
+ (with-directory-excursion "."
+ (invoke "cp" "-r" "etc/"
+ (string-append (assoc-ref outputs "out")
+ "/share/emacs/site-lisp/"
+ "telega-data/")))
+ #t))
+ (add-after 'telega-install-data 'emacs-build
(assoc-ref emacs:%standard-phases 'build))
- (add-after 'emacs-install 'emacs-make-autoloads
+ (add-after 'emacs-build 'emacs-make-autoloads
(assoc-ref emacs:%standard-phases 'make-autoloads)))))
(propagated-inputs
`(("emacs-visual-fill-column" ,emacs-visual-fill-column)))
--
2.24.0