diff mbox series

[bug#40253] gnu: neofetch: update to 7.0.0

Message ID 87ftdt4wzg.fsf@rohleder.de
State Accepted
Headers show
Series [bug#40253] gnu: neofetch: update to 7.0.0 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Michael Rohleder March 27, 2020, 3:51 p.m. UTC
* gnu/packages/admin.scm (neofetch): update to 7.0.0

Comments

Leo Famulari March 27, 2020, 8:44 p.m. UTC | #1
On Fri, Mar 27, 2020 at 04:51:31PM +0100, Michael Rohleder wrote:
> * gnu/packages/admin.scm (neofetch): update to 7.0.0

> From 8ccb90034ea1aee54b51232b48748b937848aa19 Mon Sep 17 00:00:00 2001
> From: Michael Rohleder <mike@rohleder.de>
> Date: Fri, 27 Mar 2020 16:46:40 +0100
> Subject: [PATCH] * gnu/packages/admin.scm (neofetch): update to 7.0.0

Thanks! Pushed as 816bce684c2fd5cc1908e27fde2891ecdf25e378 after fixing
cosmetic issues with the commit message (capitalization and
punctuation).
Michael Rohleder March 28, 2020, 5:50 p.m. UTC | #2
close 40253
diff mbox series

Patch

From 8ccb90034ea1aee54b51232b48748b937848aa19 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Fri, 27 Mar 2020 16:46:40 +0100
Subject: [PATCH] * gnu/packages/admin.scm (neofetch): update to 7.0.0

---
 gnu/packages/admin.scm | 50 +++++++++++++++++++++---------------------
 1 file changed, 25 insertions(+), 25 deletions(-)

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 4d3425d039..b2b5111458 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -31,6 +31,7 @@ 
 ;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2927,35 +2928,34 @@  tool for remote execution and deployment.")
     (license license:bsd-2)))
 
 (define-public neofetch
-  (let ((commit "501d6b7594296d9eac8943140f8581daf555873d"))
-    (package
-      (name "neofetch")
-      (version (git-version "6.1.0" "1" commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/dylanaraps/neofetch")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "1h5md9jimyc6z4d7w66j27hn8qghzyxgpkh5h9dclzxpp5cs8whb"))))
-      (build-system gnu-build-system)
-      (arguments
-       `(#:tests? #f                      ; there are no tests
-         #:make-flags
-         (list (string-append "PREFIX=" %output))
-         #:phases
-         (modify-phases %standard-phases
-           (delete 'configure))))         ; no configure script
-      (home-page "https://github.com/dylanaraps/neofetch")
-      (synopsis "System information script")
-      (description "Neofetch is a command-line system information tool written in
+  (package
+    (name "neofetch")
+    (version "7.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/dylanaraps/neofetch")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0xc0fdc7n5bhqirh83agqiy8r14l14zwca07czvj8vgnsnfybslr"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f                      ; there are no tests
+       #:make-flags
+       (list (string-append "PREFIX=" %output))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))))         ; no configure script
+    (home-page "https://github.com/dylanaraps/neofetch")
+    (synopsis "System information script")
+    (description "Neofetch is a command-line system information tool written in
 Bash.  Neofetch displays information about your system next to an image, your OS
 logo, or any ASCII file of your choice.  The main purpose of Neofetch is to be
 used in screenshots to show other users what operating system or distribution
 you are running, what theme or icon set you are using, etc.")
-      (license license:expat))))
+    (license license:expat)))
 
 (define-public screenfetch
   (package
-- 
2.26.0