diff mbox series

[bug#40259] gnu: Add emacs-evil-tmux-navigator

Message ID 87ftds42xp.fsf@asu.edu
State Accepted
Headers show
Series [bug#40259] gnu: Add emacs-evil-tmux-navigator | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

John Soo March 28, 2020, 8:52 p.m. UTC
Hi Guix,

I realized my last patch was based on previous work.

I cherry-picked this one onto master.

Thanks,

John

Comments

Christopher Baines April 1, 2020, 8:11 a.m. UTC | #1
John Soo <jsoo1@asu.edu> writes:

> Hi Guix,
>
> I realized my last patch was based on previous work.
>
> I cherry-picked this one onto master.

Hi John,

Thanks for the patch. I've now pushed this as
1d5c93d9f8a13588695490db6516b40f54e91fa2.

I made a few changes, I move the package up from the bottom of the
file. I'd always recommend not adding new packages at the bottom of the
module files, as if everyone does this, it becomes harder to apply
patches because there are more conflicts. In this case, I think this
patch ended up conflicting with your addition of emacs-haskell-snippets,
also to the bottom of the emacs-xyz.scm file.

I also tweaked emacs-evil to be a propagated input, just because that
looked to be what the existing emacs-evil-... packages do, and I tweaked
the description to start with "This package lets you " so it reads as a
complete sentance.

Thanks again,

Chris
diff mbox series

Patch

>From dfb75bb602bcea6c7a7a59f6b18bf0f0abad0489 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 19 Mar 2020 09:27:15 -0700
Subject: [PATCH] gnu: Add emacs-evil-tmux-navigator.

* gnu/packages/emacs-xyz.scm (emacs-evil-tmux-navigator): New Variable.
---
 gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 86033fd200..c69af1e4a4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -65,6 +65,7 @@ 
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2020 6033fe7de85d <6033fe7de85d@airmail.cc>
+;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21774,3 +21775,29 @@  enables modal editing and composition of commands, too.  It combines ideas of
 other Editors like Vim or Kakoune and tries to align them with regular Emacs
 conventions.")
     (license license:gpl3+)))
+
+(define-public emacs-evil-tmux-navigator
+  (package
+    (name "emacs-evil-tmux-navigator")
+    (version "0.1.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/keith/evil-tmux-navigator")
+         (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1na44rbc03sr5b4z9pvnps6n4nmrqcz58nywix9825l74a419ijx"))))
+    (inputs
+     `(("emacs-evil" ,emacs-evil)))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/keith/evil-tmux-navigator")
+    (synopsis
+     "Navigate seamlessly between emacs windows and tmux panes")
+    (description
+     "Use C-h, C-j, C-k and C-l to navigate between emacs windows and tmux
+panes.")
+    (license license:expat)))
-- 
2.26.0