diff mbox series

[bug#40556] gnu: dovecot: Add libunwind input.

Message ID 87ftdahvut.fsf@gmx.com
State Accepted
Headers show
Series [bug#40556] gnu: dovecot: Add libunwind input. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Pierre Langlois April 11, 2020, 3:42 p.m. UTC
Hi Guix, Julien,

I noticed I couldn't build dovecot on either aarch64 or arm :-/. I did a
little bit of debugging, and it looks like the backtrace_symbols()
function isn't working correctly. Dovecot is able to use libunwind
instead, and this appears to work.

I then noticed it was reported upstream already, coming to the same
conclusion https://markmail.org/message/fjgo7lkuk7tk4iek

I wonder what's wrong with backtrace_symbols() in guix, I'm not sure how
to investigate that. For now though, what do you think of using
libunwind?

Thanks,
Pierre

Comments

ashish.is--- via Guix-patches" via April 11, 2020, 4:17 p.m. UTC | #1
Pierre,

Pierre Langlois 写道:
> I wonder what's wrong with backtrace_symbols() in guix, I'm not 
> sure how
> to investigate that. For now though, what do you think of using
> libunwind?

OK, but it should only be included on platforms that require it:

  ;; Untested…
  (inputs
   `(…
     ,@(match (%current-system)
         ((or "aarch64-linux" "armhf-linux" …)
          `(("libunwind" ,libunwind)))
         (_ `()))
     …))

Could you test that?

Kind regards,

T G-R
diff mbox series

Patch

From b95b8f4769f5543d196fe7e334a891f8fe276816 Mon Sep 17 00:00:00 2001
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Sat, 11 Apr 2020 16:34:01 +0100
Subject: [PATCH] gnu: dovecot: Add libunwind input.

* gnu/packages/mail.scm (dovecot)[inputs]: Add libunwind.
---
 gnu/packages/mail.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index a6ed776db1..4ea8fb6051 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -24,7 +24,7 @@ 
 ;;; Copyright © 2017 Kyle Meyer <kyle@kyleam.com>
 ;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017, 2018 Rene Saavedra <pacoon@protonmail.com>
-;;; Copyright © 2018, 2019 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2018, 2019, 2020 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
 ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
 ;;; Copyright © 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
@@ -89,6 +89,7 @@ 
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages libidn)
   #:use-module (gnu packages libunistring)
+  #:use-module (gnu packages libunwind)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages lsof)
   #:use-module (gnu packages lua)
@@ -1435,6 +1436,7 @@  facilities for checking incoming mail.")
     (inputs
      `(("bzip2" ,bzip2)
        ("libsodium" ,libsodium)         ; extra password algorithms
+       ("libunwind" ,libunwind)
        ("linux-pam" ,linux-pam)
        ("lz4" ,lz4)
        ("openssl" ,openssl)
-- 
2.26.0