diff mbox series

[bug#40873] gnu: Add emacs-toml-mode.

Message ID 87ftcqw6x0.fsf@odyssey.lafreniere.xyz
State Accepted
Headers show
Series [bug#40873] gnu: Add emacs-toml-mode. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

LaFreniere, Joseph April 26, 2020, 4:25 p.m. UTC
Patch file is attached.

--
Joseph LaFreniere

Comments

Nicolas Goaziou April 28, 2020, 3:28 p.m. UTC | #1
Hello,

"LaFreniere, Joseph" <joseph@lafreniere.xyz> writes:

> Subject: [PATCH] gnu: Add emacs-toml-mode.

Applied. Thank you.

Regards,
diff mbox series

Patch

From 786fea6efde51a5a2ddc5eee95295d82661157d6 Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Sun, 26 Apr 2020 11:24:32 -0500
Subject: [PATCH] gnu: Add emacs-toml-mode.

* gnu/packages/emacs-xyz.scm (emacs-toml-mode): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 17aea794c4..41cb10a2a7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2584,6 +2584,30 @@  strings.")
 Stack Overflow, Super User, and other StackExchange sites.")
       (license license:gpl3+))))
 
+(define-public emacs-toml-mode
+  (let ((version "0.1.3")
+        (revision "0")
+        (commit "f6c61817b00f9c4a3cab1bae9c309e0fc45cdd06"))
+    (package
+      (name "emacs-toml-mode")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/dryman/toml-mode.el.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "05b4ksay85c8y5ncax0qsvnmplwsfiw24z16a58gkarjz938hb57"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/dryman/toml-mode.el")
+      (synopsis "Major mode for editing TOML files")
+      (description
+       "This package provides a major mode for editing files in TOML data
+format.")
+      (license license:gpl3+))))
+
 (define-public emacs-f
   (package
     (name "emacs-f")
-- 
2.26.2