diff mbox series

[bug#40910] Add apt-mirror package

Message ID 87ftcok8sd.fsf@m4x.org
State Accepted
Headers show
Series [bug#40910] Add apt-mirror package | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Jean-Baptiste Note April 27, 2020, 7:50 p.m. UTC
Dear guix maintainers,

Please find attached a patch adding the apt-mirror utility as a package.

I've tried to follow the guidelines (thanks for such detailed
instructions), please advise any mistake.

Kind regards,
Jean-Baptiste

Comments

Ludovic Courtès April 30, 2020, 11:14 p.m. UTC | #1
Hi,

Jean-Baptiste Note <jean-baptiste.note@m4x.org> skribis:

> From 82ad467853beae1969720323b4b19d49ed69c2f0 Mon Sep 17 00:00:00 2001
> From: Jean-Baptiste Note <jean-baptiste.note@m4x.org>
> Date: Sun, 26 Apr 2020 05:59:48 -0400
> Subject: [PATCH] gnu: Add apt-mirror.
>
> * gnu/packages/debian.scm (apt-mirror): New variable.

Applied.  Thanks, and welcome!  :-)

Ludo’.
diff mbox series

Patch

From 82ad467853beae1969720323b4b19d49ed69c2f0 Mon Sep 17 00:00:00 2001
From: Jean-Baptiste Note <jean-baptiste.note@m4x.org>
Date: Sun, 26 Apr 2020 05:59:48 -0400
Subject: [PATCH] gnu: Add apt-mirror.

* gnu/packages/debian.scm (apt-mirror): New variable.
---
 gnu/packages/debian.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

diff --git a/gnu/packages/debian.scm b/gnu/packages/debian.scm
index ff4cccb03d..a3bbd2b907 100644
--- a/gnu/packages/debian.scm
+++ b/gnu/packages/debian.scm
@@ -27,6 +27,7 @@ 
   #:use-module (gnu packages base)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages gnupg)
+  #:use-module (gnu packages wget)
   #:use-module (gnu packages perl))
 
 (define-public debian-archive-keyring
@@ -190,3 +191,40 @@  scratch, without requiring the availability of @code{dpkg} or @code{apt}.
 It does this by downloading .deb files from a mirror site, and carefully
 unpacking them into a directory which can eventually be chrooted into.")
     (license license:gpl2)))
+
+
+(define-public apt-mirror
+  (let ((commit "e664486a5d8947c2579e16dd793d762ea3de4202")
+        (revision "1"))
+    (package
+      (name "apt-mirror")
+      (version (git-version "0.5.4" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/apt-mirror/apt-mirror/")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0qj6b7gldwcqyfs2kp6amya3ja7s4vrljs08y4zadryfzxf35nqq"))))
+      (build-system gnu-build-system)
+      (outputs '("out"))
+      (arguments
+       `(#:tests? #f
+         ;; sysconfdir is not PREFIXed in the makefile but DESTDIR is
+         ;; honored correctly; we therefore use DESTDIR for our
+         ;; needs. A more correct fix would involve patching.
+         #:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out"))
+                            "PREFIX=/")
+         #:phases (modify-phases %standard-phases (delete 'configure))))
+      (inputs
+       `(("wget" ,wget)
+         ("perl" ,perl)))
+      (home-page "http://apt-mirror.github.io/")
+      (synopsis "Script for mirroring a Debian repository")
+      (description
+       "apt-mirror is a small tool that provides the ability to
+selectively mirror Debian and Ubuntu GNU/Linux distributions or any
+other apt sources typically provided by open source developers.")
+      (license license:gpl2))))
-- 
2.26.1