diff mbox series

[bug#41327] gnu: Add emacs-vcsh.

Message ID 87ftbz986g.fsf@rohleder.de
State Accepted
Headers show
Series [bug#41327] gnu: Add emacs-vcsh. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Michael Rohleder May 16, 2020, 4:05 p.m. UTC

Comments

Nicolas Goaziou May 16, 2020, 5:19 p.m. UTC | #1
Hello,

Michael Rohleder <mike@rohleder.de> writes:

> From f18c71cbad9860ae15907c5a74367b8ac55cb122 Mon Sep 17 00:00:00 2001
> From: Michael Rohleder <mike@rohleder.de>
> Date: Sat, 16 May 2020 18:01:49 +0200
> Subject: [PATCH] gnu: Add emacs-vcsh.

Thank you for the patch. Some comments follow.

> +(define-public emacs-vcsh
> +  (package
> +    (name "emacs-vcsh")
> +    (version "0.4.4")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://gitlab.com/stepnem/vcsh-el.git")
> +             (commit version)))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> +         "183pffdiqb7qqmjq31wxl3fpv8qswqgg99gb716rddiyk15ysri7"))))

Nitpick: could you move the string on the line above?

> +    (build-system emacs-build-system)
> +    (home-page "https://gitlab.com/stepnem/vcsh-el")
> +    (synopsis "Emacs vcsh integration")
> +    (description
> +     "This library only provides basic \"enter\" functionality
> +(`vcsh-link', `vcsh-unlink') and a few convenience commands
> +(`vcsh-new' to init a repo and add files to it,
> +`vcsh-write-gitignore').

Without writing too many details, I suggest

  This library provides basic ``enter'' functionality and a few
  convenience commands to init a repository and add files to it.

However, it may be useful to write somewhere what is "vcsh". As a user,
do I need/want that?

> +Please note that this library works by creating a regular file
> +named \".git\" inside $VCSH_BASE directory (typically $HOME) and does
> +not remove this file automatically, so don't be surprised if your
> +shell suddenly behaves as after \"vcsh enter\" when inside that
> +directory.  You can use `vcsh-unlink' or simply remove the file to
> +get rid of it."

I don't think this part is really useful as a description, i.e., it does
belong to a manual instead. As a side note, descriptions use Texinfo
syntax, so `vcsh-unlink' is written @code{vcsh-unlink}, etc.


Could you send an updated patch?

Regards,
diff mbox series

Patch

From f18c71cbad9860ae15907c5a74367b8ac55cb122 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Sat, 16 May 2020 18:01:49 +0200
Subject: [PATCH] gnu: Add emacs-vcsh.

* gnu/packages/emacs-xyz.scm (emacs-vcsh): New variable.
---
 gnu/packages/emacs-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 45ccced99e..ac299b34ce 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14918,6 +14918,36 @@  repository, @code{magit-org-todos} will create a section in your Magit status
 buffer with each of your todos.")
       (license license:gpl3+))))
 
+(define-public emacs-vcsh
+  (package
+    (name "emacs-vcsh")
+    (version "0.4.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.com/stepnem/vcsh-el.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "183pffdiqb7qqmjq31wxl3fpv8qswqgg99gb716rddiyk15ysri7"))))
+    (build-system emacs-build-system)
+    (home-page "https://gitlab.com/stepnem/vcsh-el")
+    (synopsis "Emacs vcsh integration")
+    (description
+     "This library only provides basic \"enter\" functionality
+(`vcsh-link', `vcsh-unlink') and a few convenience commands
+(`vcsh-new' to init a repo and add files to it,
+`vcsh-write-gitignore').
+Please note that this library works by creating a regular file
+named \".git\" inside $VCSH_BASE directory (typically $HOME) and does
+not remove this file automatically, so don't be surprised if your
+shell suddenly behaves as after \"vcsh enter\" when inside that
+directory.  You can use `vcsh-unlink' or simply remove the file to
+get rid of it.")
+    (license license:public-domain)))
+
 (define-public emacs-f3
   (package
     (name "emacs-f3")
-- 
2.26.2