diff mbox series

[bug#41620] gnu: python-astroid: Update to 2.4.1.

Message ID 87ftbhyx9a.fsf@rohleder.de
State Accepted
Headers show
Series [bug#41620] gnu: python-astroid: Update to 2.4.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Michael Rohleder May 30, 2020, 8:37 p.m. UTC
on current (8e3a1a62ae) master, gnome doesnt build, because totem tests
fail.
in order to fix this, i tried adding python-toml and python-astroid to
native-inputs of totem.
then the tests fail, because python-astroid seems to old, so here is a
patch for that.
now, the tests still fail, but we might be a small step closer... ;)

I only tested this lightly with building the other 3 deps:
"python-language-server rtv tuir" and python2-astroid.

Comments

Marius Bakke May 30, 2020, 9:15 p.m. UTC | #1
Michael Rohleder <mike@rohleder.de> writes:

> on current (8e3a1a62ae) master, gnome doesnt build, because totem tests
> fail.
> in order to fix this, i tried adding python-toml and python-astroid to
> native-inputs of totem.
> then the tests fail, because python-astroid seems to old, so here is a
> patch for that.
> now, the tests still fail, but we might be a small step closer... ;)

Uff, thanks for the heads-up, I have reverted the pylint update.

> I only tested this lightly with building the other 3 deps:
> "python-language-server rtv tuir" and python2-astroid.

Heh, that's what I did too because I did not have WebKitGTK readily
available for testing the Totem build.  ;-)

However now I do, and can confirm that Totem still builds with this
patch.

I also added a follow-up patch to remove the unused nose and typing-ast
inputs.

Applied!
diff mbox series

Patch

From 7b4e21f9709b642f20695c9ea6a8e512baa808da Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Sat, 30 May 2020 21:27:49 +0200
Subject: [PATCH] gnu: python-astroid: Update to 2.4.1.

* gnu/packages/python-xyz.scm (python-astroid): Update to 2.4.1.
---
 gnu/packages/python-xyz.scm | 18 +++---------------
 1 file changed, 3 insertions(+), 15 deletions(-)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index baec999247..79816ddc2f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -80,6 +80,7 @@ 
 ;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
 ;;; Copyright © 2020 Josh Holland <josh@inv.alid.pw>
 ;;; Copyright © 2020 Yuval Kogman <nothingmuch@woobling.org>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -13905,13 +13906,13 @@  clone, while other processes access the original tree.")
 (define-public python-astroid
   (package
     (name "python-astroid")
-    (version "2.3.3")
+    (version "2.4.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "astroid" version))
        (sha256
-        (base32 "0fnibsl2cb5mvzbfm7sycj85smx48f8w8m7ks1sqlmpr9ps0gski"))))
+        (base32 "1h99jal7ax07xna1djw5z7hpgb8vjrl3hrrg49p1phljwniww5sc"))))
     (build-system python-build-system)
     (propagated-inputs
      `(("python-lazy-object-proxy" ,python-lazy-object-proxy)
@@ -13923,19 +13924,6 @@  clone, while other processes access the original tree.")
        ("python-nose" ,python-nose)
        ("python-pytest" ,python-pytest)
        ("python-pytest-runner" ,python-pytest-runner)))
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'remove-spurious-test
-           (lambda _
-             ;; This can be removed after upgrading from python-3.7
-             ;; https://github.com/PyCQA/astroid/issues/593
-             ;; https://bugs.python.org/issue34056
-             (delete-file "astroid/tests/unittest_modutils.py")
-             #t))
-         (replace 'check
-           (lambda _
-             (invoke "pytest" "astroid"))))))
     (home-page "https://github.com/PyCQA/astroid")
     (synopsis "Common base representation of python source code for pylint and
 other projects")
-- 
2.26.2