diff mbox series

[bug#41459] (no subject)

Message ID 87ftbddco7.fsf@alice.lan
State Accepted
Headers show
Series [bug#41459] (no subject) | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Edouard Klein June 2, 2020, 9:44 a.m. UTC
Subject: [PATCH 3/4] gnu: Add python-pytest-flask
* gnu/packages/python-check.scm (python-pytest-flask): New variable.
---
 gnu/packages/python-check.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Marius Bakke June 22, 2020, 7:39 p.m. UTC | #1
Edouard Klein <edk@beaver-labs.com> writes:

> Subject: [PATCH 3/4] gnu: Add python-pytest-flask
> * gnu/packages/python-check.scm (python-pytest-flask): New variable.

Applied with a minor tweak to the description.
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index b13b750bbd..d7bed91a04 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -384,6 +384,30 @@  for the @code{pytest} framework.")
 the chosen timer.")
     (license license:bsd-2)))
 
+(define-public python-pytest-flask
+  (package
+    (name "python-pytest-flask")
+    (version "1.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-flask" version))
+       (sha256
+        (base32
+         "1hln7mwgdzfi5ma0kqfsi768l7p24jhkw8l0imhifwy08nh7hmjd"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-flask" ,python-flask)
+       ("python-pytest" ,python-pytest)
+       ("python-setuptools-scm" ,python-setuptools-scm)
+       ("python-werkzeug" ,python-werkzeug)))
+    (home-page
+     "https://github.com/pytest-dev/pytest-flask")
+    (synopsis "Pytest fixtures to test Flask applications")
+    (description
+     "This pytest plugin provides some fixtures to simplify app testing.")
+    (license license:expat)))
+
 (define-public python-codacy-coverage
   (package
     (name "python-codacy-coverage")