diff mbox series

[bug#44003,v3] gnu: emacs-julia-mode: Update to 0.4.

Message ID 87ft6c1o8l.fsf@lavabit.com
State Accepted
Headers show
Series [bug#44003,v3] gnu: emacs-julia-mode: Update to 0.4. | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Tim Howes Oct. 17, 2020, 10:28 p.m. UTC
Brett Gilio writes:

> Using tagged releases is preferred. I would remove the commit
> let-binding and go about it using version numbering.

OK, sounds good. Here it is using just the version tag.

Thanks,
Tim

Comments

Ludovic Courtès Nov. 2, 2020, 1:46 p.m. UTC | #1
Hi Tim,

Tim Howes <timhowes@lavabit.com> skribis:

>>From 56fb736e24782937283eda7a3c4ea6b25c2d1014 Mon Sep 17 00:00:00 2001
> From: Tim Howes <timhowes@lavabit.com>
> Date: Thu, 15 Oct 2020 19:52:04 -0700
> Subject: [PATCH v3] gnu: emacs-julia-mode: Update to 0.4.
>
> * gnu/packages/emacs-xyz.scm (emacs-julia-mode): Update to 0.4.

Applied, thanks!  And sorry for the delay.

Ludo’.
diff mbox series

Patch

From 56fb736e24782937283eda7a3c4ea6b25c2d1014 Mon Sep 17 00:00:00 2001
From: Tim Howes <timhowes@lavabit.com>
Date: Thu, 15 Oct 2020 19:52:04 -0700
Subject: [PATCH v3] gnu: emacs-julia-mode: Update to 0.4.

* gnu/packages/emacs-xyz.scm (emacs-julia-mode): Update to 0.4.
---
 gnu/packages/emacs-xyz.scm | 13 +++++--------
 1 file changed, 5 insertions(+), 8 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e3e61e3141..d2fb4aaadb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -81,6 +81,7 @@ 
 ;;; Copyright © 2020 Niklas Eklund <niklas.eklund@posteo.net>
 ;;; Copyright © 2020 Marco Grassi <marco.au.grassi98@protonmail.com>
 ;;; Copyright © 2020 Tomás Ortín Fernández <tomasortin@mailbox.org>
+;;; Copyright © 2020 Tim Howes <timhowes@lavabit.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -7786,23 +7787,19 @@  E-Prime forbids the use of the \"to be\" form to strengthen your writing.")
       (license license:gpl3+))))
 
 (define-public emacs-julia-mode
-  ;; XXX: Upstream version remained stuck at 0.3.  See
-  ;; <https://github.com/JuliaEditorSupport/julia-emacs/issues/46>.
-  (let ((commit "115d4dc8a07445301772da8376b232fa8c7168f4")
-        (revision "1"))
     (package
       (name "emacs-julia-mode")
-      (version (string-append "0.3-" revision "." (string-take commit 8)))
+      (version "0.4")
       (source
        (origin
          (method git-fetch)
          (uri (git-reference
                (url "https://github.com/JuliaEditorSupport/julia-emacs")
-               (commit commit)))
+               (commit version)))
          (file-name (git-file-name name version))
          (sha256
           (base32
-           "1is4dcv6blslpzbjcg8l2jpxi8xj96q4cm0nxjxsyswpm8bw8ki0"))))
+           "1w131jb9mhvyjxa0p93iwfhzidgbcs6b8i6jg79yisqb9wchik99"))))
       (build-system emacs-build-system)
       (arguments
        `(#:tests? #t
@@ -7813,7 +7810,7 @@  E-Prime forbids the use of the \"to be\" form to strengthen your writing.")
       (synopsis "Major mode for Julia")
       (description "This Emacs package provides a mode for the Julia
 programming language.")
-      (license license:expat))))
+      (license license:expat)))
 
 (define-public emacs-smex
   (package
-- 
2.28.0