diff mbox series

bug#46603: [PATCH 1/1] gnu: Add camlidl

Message ID 87ft03jcsq.fsf@gnu.org
State Accepted
Headers show
Series bug#46603: [PATCH 1/1] gnu: Add camlidl | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ludovic Courtès April 6, 2021, 9:58 p.m. UTC
Hi Sharlatan,

Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

> From ce12e3783ad0e63a73a7ddc3471a0c82083b6283 Mon Sep 17 00:00:00 2001
> From: Sharlatan Hellseher <sharlatanus@gmail.com>
> Date: Wed, 17 Feb 2021 22:45:08 +0000
> Subject: [PATCH] gnu: Add camlidl
>
> * gnu/packages/ocaml.scm (camlidl): New variable.

Applied with the minor changes below.  Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 82a2aac812..0948377d08 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -478,7 +478,8 @@  for building OCaml library and programs.")
              (url "https://github.com/xavierleroy/camlidl")
              (commit "camlidl109")))
        (sha256
-        (base32 "0zrkaq7fk23b2b9vg6jwdjx7l0hdqp4synbbrw1zcg8gjf6n3c80"))))
+        (base32 "0zrkaq7fk23b2b9vg6jwdjx7l0hdqp4synbbrw1zcg8gjf6n3c80"))
+       (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f ;; No test suite
@@ -493,10 +494,10 @@  for building OCaml library and programs.")
          (delete 'configure)
          (replace 'build
            (lambda _
-             (let* ((cores  (parallel-job-count))
-                    (dash-j (format #f "-j~a" cores)))
-               (copy-file "config/Makefile.unix" "config/Makefile")
-               (invoke "make" dash-j "all"))
+             (copy-file "config/Makefile.unix" "config/Makefile")
+             ;; Note: do not pass '-jN' as this appears to not be
+             ;; parallel-safe (race condition related to libcamlidl.a).
+             (invoke "make" "all")
              #t))
          (add-before 'install 'create-target-directories
            (lambda* (#:key outputs #:allow-other-keys)