diff mbox series

bug#48997: [PATCH] gnu: Add ausweisapp2.

Message ID 87fsx7rlhy.fsf_-_@gnu.org
State Accepted
Headers show
Series bug#48997: [PATCH] gnu: Add ausweisapp2. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ludovic Courtès June 24, 2021, 9:38 p.m. UTC
Hi,

Sergey Trofimov <sarg@sarg.org.ru> skribis:

> * gnu/packages/security-token.scm (ausweisapp2): New variable.
> * guix/licenses.scm (eupl1.2): New variable.

Applied with the changes below.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 555b8216a2..49ca1dc01e 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -10,6 +10,7 @@ 
 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2020 Raphaël Mélotte <raphael.melotte@mind.be>
 ;;; Copyright © 2021 Antero Mejr <antero@kodmin.com>
+;;; Copyright © 2021 Sergey Trofimov <sarg@sarg.org.ru>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -739,14 +740,15 @@  devices.")
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("qttools" ,qttools)))
-    (inputs `(("qtbase" ,qtbase)
-              ("qtsvg" ,qtsvg)
-              ("qtdeclarative" ,qtdeclarative)
-              ("qtwebsockets" ,qtwebsockets)
-              ("qtgraphicaleffects" ,qtgraphicaleffects)
-              ("qtquickcontrols2" ,qtquickcontrols2)
-              ("pcsc-lite" ,pcsc-lite)
-              ("openssl" ,openssl)))
+    (inputs
+     `(("qtbase" ,qtbase-5)
+       ("qtsvg" ,qtsvg)
+       ("qtdeclarative" ,qtdeclarative)
+       ("qtwebsockets" ,qtwebsockets)
+       ("qtgraphicaleffects" ,qtgraphicaleffects)
+       ("qtquickcontrols2" ,qtquickcontrols2)
+       ("pcsc-lite" ,pcsc-lite)
+       ("openssl" ,openssl)))
     (arguments
      `(#:modules ((guix build cmake-build-system)
                   (guix build qt-utils)
@@ -755,15 +757,15 @@  devices.")
                            (guix build qt-utils))
        #:phases
        (modify-phases %standard-phases
-                      (add-after 'install 'wrap-qt
-                                 (lambda* (#:key outputs #:allow-other-keys)
-                                          (wrap-qt-program (assoc-ref outputs "out") "AusweisApp2")
-                                          #t)))))
+         (add-after 'install 'wrap-qt
+           (lambda* (#:key outputs #:allow-other-keys)
+             (wrap-qt-program (assoc-ref outputs "out") "AusweisApp2"))))))
     (home-page "https://github.com/Governikus/AusweisApp2")
     (synopsis
-     "Official authentication app for German ID cards and residence permits")
+     "Authentication program for German ID cards and residence permits")
     (description
-     "This app is developed and issued by the German government to be used for online
-authentication with electronic German ID cards and residence titles. To use this app,
-a supported RFID card reader or NFC-enabled smart phone is required.")
+     "This application is developed and issued by the German government to be
+used for online authentication with electronic German ID cards and residence
+titles.  To use this app, a supported RFID card reader or NFC-enabled smart
+phone is required.")
     (license license:eupl1.2)))