diff mbox series

[bug#54089] gnu: Add emacs-highlight-doxygen

Message ID 87fsoc9mi0.fsf@posteo.net
State Accepted
Headers show
Series [bug#54089] gnu: Add emacs-highlight-doxygen | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Niklas Eklund Feb. 21, 2022, 5:07 p.m. UTC
Hello,

here is a patch adding the highlight-doxygen package for Emacs.

Best regards,

Niklas Eklund

Comments

Nicolas Goaziou Feb. 22, 2022, 10:35 a.m. UTC | #1
Hello,

Niklas Eklund <niklas.eklund@posteo.net> writes:

> here is a patch adding the highlight-doxygen package for Emacs.

Thank you. I applied your patch with the changes explained below.

> +(define-public emacs-highlight-doxygen
> +  ;; Upstream does not tag releases.  Commit below matches version bump.
> +  (let ((commit "eec4874e2e89d4eb39091aad89a67dff8f8ec84c")
> +        (revision "0"))
> +    (package
> +      (name "emacs-highlight-doxygen")
> +      (version (git-version "0.0.2" revision commit))

Since commit matches version bump, you don't need GIT-VERSION at all.
I removed REVISION binding, and wrote:

  (version "0.0.2")

> +      (description
> +       "Advanced highlighting package for Doxygen comments.

This is not a complete sentence. I wrote

  This package highlights Doxygen comments.

Regards,
diff mbox series

Patch

From 8bd74db7e27879b5efb0656614aec4c5e3e7384e Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Mon, 21 Feb 2022 17:52:40 +0100
Subject: [PATCH] gnu: Add emacs-highlight-doxygen.

* gnu/packages/emacs-xyz.scm (emacs-highlight-doxygen): New variable.
---
 gnu/packages/emacs-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3b909b8d0d..389be930fe 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27539,6 +27539,35 @@  (define-public emacs-flycheck-cpplint
       (home-page "https://github.com/flycheck/flycheck-google-cpplint")
       (license license:gpl3+))))
 
+(define-public emacs-highlight-doxygen
+  ;; Upstream does not tag releases.  Commit below matches version bump.
+  (let ((commit "eec4874e2e89d4eb39091aad89a67dff8f8ec84c")
+        (revision "0"))
+    (package
+      (name "emacs-highlight-doxygen")
+      (version (git-version "0.0.2" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/Lindydancer/highlight-doxygen")
+               (commit commit)))
+         (sha256
+          (base32
+           "0r3rv1px43r265716l3g20c1ss4381h1mc1kjxin22vdmrj6cmxy"))
+         (file-name (git-file-name name version))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/Lindydancer/highlight-doxygen")
+      (synopsis "Highlight Doxygen comments in Emacs, including code blocks")
+      (description
+       "Advanced highlighting package for Doxygen comments.
+
+In addition to highlighting Doxygen commands and their arguments, entire
+Doxygen comment are highlighted, making them stand out compared to other
+comments.  The code blocks are highlighted according to the
+language they are written in.")
+      (license license:gpl3+))))
+
 (define-public emacs-helm-fish-completion
   (package
     (name "emacs-helm-fish-completion")
-- 
2.34.0