diff mbox series

[bug#53717,v2] gnu: Add rofi-wayland.

Message ID 87fsma23w6.fsf@trop.in
State New
Headers show
Series [bug#53717,v2] gnu: Add rofi-wayland. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Andrew Tropin April 18, 2022, 8:26 a.m. UTC
* gnu/packages/xdisorg.scm (rofi-wayland): New variable.
---
Tested on sway session.

 gnu/packages/xdisorg.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index d2caee85ec..3ba79e178b 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -54,6 +54,7 @@ 
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
 ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1742,6 +1743,41 @@  (define-public rofi
 by name.")
     (license license:expat)))
 
+(define-public rofi-wayland
+  (package
+   (inherit rofi)
+   (name "rofi-wayland")
+   (version "1.7.3+wayland1")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "https://github.com/lbonn/rofi"
+                                "/releases/download/"
+                                version "/rofi-" version ".tar.xz"))
+            (sha256
+             (base32
+              "1gfs13zfqg9f4prx8yylxvv93yr6j74nmhlm3wabr6jljbbr7jc8"))))
+   (build-system meson-build-system)
+   (arguments
+    (substitute-keyword-arguments (package-arguments rofi)
+      ((#:configure-flags flags '())
+       #~(list "-Dxcb=disabled"))))
+    (inputs
+     (list cairo
+           glib
+           libjpeg-turbo
+           librsvg
+           libxkbcommon
+           wayland
+           wayland-protocols
+           pango
+           startup-notification))
+    (home-page "https://github.com/lbonn/rofi")
+    (description "Rofi is a minimalist application launcher.  It memorizes which
+applications you regularly use and also allows you to search for an application
+by name.
+
+This is a fork with added support for Wayland via layer shell protocol.")))
+
 (define-public rofi-calc
   (package
     (name "rofi-calc")