@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2021 Olivier Dion <olivier.dion@polymtl.ca>
+;;; Copyright © 2021, 2022 Olivier Dion <olivier.dion@polymtl.ca>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -220,11 +220,11 @@ (define-public lttng-modules
"1vm9nnjvid7acsvgwnjyxd60ih9rmbhnfjldxip58n8x9q7d0nb1"))))
(build-system linux-module-build-system)
(arguments
- `(#:tests? #f
- #:make-flags (list "CONFIG_LTTNG=m" "CONFIG_LTTNG_CLOCK_PLUGIN_TEST=m")))
+ `(#:tests? #f ; no tests
+ #:make-flags (list "CONFIG_LTTNG=m"
+ "CONFIG_LTTNG_CLOCK_PLUGIN_TEST=m")))
(home-page "https://lttng.org/")
- (synopsis "LTTng modules provide kernel tracing capability to the LTTng
-tracer toolset")
+ (synopsis "LTTng kernel modules for the LTTng tracer toolset")
(description
"LTTng kernel modules are Linux kernel modules which make
LTTng kernel tracing possible. They include essential control modules and
> * gnu/packages/instrumentation.scm (lttng-modules): New variable. Pushed with the following changes: --8<---------------cut here---------------start------------->8--- --8<---------------cut here---------------end--------------->8--- Thanks, Mathieu