diff mbox series

[bug#63663] gnu: Update sbcl-nactivitypub and sbcl-njson.

Message ID 87fs7nyw0p.fsf@aartaka.me
State New
Headers show
Series [bug#63663] gnu: Update sbcl-nactivitypub and sbcl-njson. | expand

Commit Message

Artyom Bologov May 23, 2023, 2:11 p.m. UTC
Hi Guix,

Attached patches update sbcl-nactivitypub and sbcl-njson to 0.0.5 and
1.1.0 respectively. The order I suppose these should be applied in is:
- sbcl-nactivitypub (because it probably fails to build against njson
  1.0.0 right now.)
- sbcl-njson (because it's backwards-compatible with 1.0.0 and doesn't
  influence nactivitypub in any way.)
Thanks,
--
Artyom Bologov.

Comments

Guillaume Le Vaillant May 24, 2023, 9:25 a.m. UTC | #1
Patches applied as 233d3bae95cc56b4f549b9d81fac4fbf5811374f and
following. I modified your patch for sbcl-njson to keep njson/cl-json in
'asd-systems', otherwise nyxt fails to build.
Thanks.
diff mbox series

Patch

From 4b94f68b97d3b93f22f28428cc43f1440d12978b Mon Sep 17 00:00:00 2001
From: Artyom Bologov <mail@aartaka.me>
Date: Tue, 23 May 2023 18:10:04 +0400
Subject: [PATCH] gnu: Update sbcl-njson to 1.1.0.

* gnu/packages/lisp-xyz.scm (sbcl-njson): Update to 1.1.0.
---
 gnu/packages/lisp-xyz.scm | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 8bed746669..e8a2eb14c9 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -26404,7 +26404,7 @@  (define-public ecl-nkeymaps
 (define-public sbcl-njson
   (package
     (name "sbcl-njson")
-    (version "1.0.0")
+    (version "1.1.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -26413,12 +26413,12 @@  (define-public sbcl-njson
               (file-name (git-file-name "cl-njson" version))
               (sha256
                (base32
-                "1apwccrvivrq57rlrw6vffrn3a5hikk10s0dndszjw5ri29b3qyd"))))
+                "02m9l77am2rlkg83dyp3jvb76ifw1y84xh3wpz6cx7h2wkxkjnl5"))))
     (build-system asdf-build-system/sbcl)
-    (inputs (list sbcl-cl-json))
+    (inputs (list sbcl-cl-json sbcl-jzon))
     (native-inputs (list sbcl-lisp-unit2))
     (arguments
-     '(#:asd-systems '("njson" "njson/cl-json")))
+     '(#:asd-systems '("njson" "njson/jzon")))
     (home-page "https://github.com/atlas-engineer/njson")
     (synopsis "JSON handling framework for Common Lisp")
     (description
@@ -26426,8 +26426,8 @@  (define-public sbcl-njson
 and process JSON data, in the minimum keystrokes/minutes possible.
 
 NJSON is parser-independent, with existing Common Lisp JSON parsers being
-loadable as additional system.  @code{cl-json} is included by default, though.
-Conveniences that NJSON provides are:
+loadable as additional system.  @code{jzon} and @code{cl-json} backends are
+included by default, though.  Conveniences that NJSON provides are:
 
 @itemize
 @item @code{encode} and @code{decode} as single entry points for JSON reading
-- 
2.39.2