diff mbox series

[bug#65044] gnu: alacritty: Install example configuration.

Message ID 87fs4zriu3.fsf@protonmail.com
State New
Headers show
Series [bug#65044] gnu: alacritty: Install example configuration. | expand

Commit Message

John Kehayias Aug. 3, 2023, 8:07 p.m. UTC
Hi guix,

A quick simple patch to include alacritty's example configuration file as part of docs (I followed e.g. Arch's packaging putting it there rather than e.g. /etc). I wasn't sure the style of copy-file vs install-file and this custom install phase so went with what seemed cleanest. Tested it builds locally.

John

Comments

Ludovic Courtès Aug. 17, 2023, 3:51 p.m. UTC | #1
Hi,

John Kehayias <john.kehayias@protonmail.com> skribis:

> From 08831e7530a1c5ef6b87e293051c4b92f10d1513 Mon Sep 17 00:00:00 2001
> Message-ID: <08831e7530a1c5ef6b87e293051c4b92f10d1513.1691093041.git.john.kehayias@protonmail.com>
> From: John Kehayias <john.kehayias@protonmail.com>
> Date: Thu, 3 Aug 2023 15:54:52 -0400
> Subject: [PATCH] gnu: alacritty: Install example configuration.
>
> * gnu/packages/terminals.scm (alacritty)[phases]{install}: Install example
> configuration.
> ---
>  gnu/packages/terminals.scm | 3 +++
>  1 file changed, 3 insertions(+)
>
> diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
> index 081ef19af1..d54910bce7 100644
> --- a/gnu/packages/terminals.scm
> +++ b/gnu/packages/terminals.scm
> @@ -1515,6 +1515,9 @@ (define-public alacritty
>                 (mkdir-p man)
>                 (copy-file "extra/alacritty.man"
>                            (string-append man "/alacritty.1"))
> +               ;; Install example configuration.
> +               (install-file "alacritty.yml"
> +                             (string-append share "/doc/alacritty-" ,version "/example"))

Nitpick: ,(package-version this-package)

That means it will pick the right version string when inheriting, as in:

  (package
    (inherit alacritty)
    (version "42.0")
    …)

Otherwise LGTM, thanks!

Ludo’.
John Kehayias Aug. 18, 2023, 3:50 p.m. UTC | #2
Hello,

On Thu, Aug 17, 2023 at 05:51 PM, Ludovic Courtès wrote:

> Hi,
>
> John Kehayias <john.kehayias@protonmail.com> skribis:
>
>> From 08831e7530a1c5ef6b87e293051c4b92f10d1513 Mon Sep 17 00:00:00 2001
>> Message-ID: <08831e7530a1c5ef6b87e293051c4b92f10d1513.1691093041.git.john.kehayias@protonmail.com>
>> From: John Kehayias <john.kehayias@protonmail.com>
>> Date: Thu, 3 Aug 2023 15:54:52 -0400
>> Subject: [PATCH] gnu: alacritty: Install example configuration.
>>
>> * gnu/packages/terminals.scm (alacritty)[phases]{install}: Install example
>> configuration.
>> ---
>>  gnu/packages/terminals.scm | 3 +++
>>  1 file changed, 3 insertions(+)
>>
>> diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
>> index 081ef19af1..d54910bce7 100644
>> --- a/gnu/packages/terminals.scm
>> +++ b/gnu/packages/terminals.scm
>> @@ -1515,6 +1515,9 @@ (define-public alacritty
>>                 (mkdir-p man)
>>                 (copy-file "extra/alacritty.man"
>>                            (string-append man "/alacritty.1"))
>> +               ;; Install example configuration.
>> +               (install-file "alacritty.yml"
>> +                             (string-append share "/doc/alacritty-" ,version "/example"))
>
> Nitpick: ,(package-version this-package)
>
> That means it will pick the right version string when inheriting, as in:
>
>   (package
>     (inherit alacritty)
>     (version "42.0")
>     …)
>

Good point, thanks.

> Otherwise LGTM, thanks!
>

Made the change and pushed as d1c811268d130041b5af1ba8f8b41cdafe8f08b5 (and followed up with another commit to update source and home-page URLs as guix lint noted a redirect.)

John
diff mbox series

Patch

From 08831e7530a1c5ef6b87e293051c4b92f10d1513 Mon Sep 17 00:00:00 2001
Message-ID: <08831e7530a1c5ef6b87e293051c4b92f10d1513.1691093041.git.john.kehayias@protonmail.com>
From: John Kehayias <john.kehayias@protonmail.com>
Date: Thu, 3 Aug 2023 15:54:52 -0400
Subject: [PATCH] gnu: alacritty: Install example configuration.

* gnu/packages/terminals.scm (alacritty)[phases]{install}: Install example
configuration.
---
 gnu/packages/terminals.scm | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 081ef19af1..d54910bce7 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1515,6 +1515,9 @@  (define-public alacritty
                (mkdir-p man)
                (copy-file "extra/alacritty.man"
                           (string-append man "/alacritty.1"))
+               ;; Install example configuration.
+               (install-file "alacritty.yml"
+                             (string-append share "/doc/alacritty-" ,version "/example"))
                ;; Install desktop file.
                (install-file "extra/linux/Alacritty.desktop"
                              (string-append share "/applications"))

base-commit: 4ded034a57ffacdd6c7afa73bb58893afd614644
-- 
2.41.0