diff mbox series

bug#62699: [PATCH v2] services: add pam-mount-volume-service-type

Message ID 87fs4spkxs.fsf@gnu.org
State New
Headers show
Series bug#62699: [PATCH v2] services: add pam-mount-volume-service-type | expand

Commit Message

Ludovic Courtès Aug. 9, 2023, 10:30 a.m. UTC
Hello,

Brian Cully <bjc@spork.org> skribis:

> The `pam-mount-volumes-service-type' adds additional volumes to the
> pam-mount-service-type in addition to any that are already specified in
> `pam-mount-rules'.
>
> * doc/guix.texi (PAM Mount Volume Service): add documentation for
> `pam-mount-service-type'.
> * gnu/services/pam-mount.scm: new file.
> * Makefile.am: add pam-mount tests
> * tests/services/pam-mount.scm: new tests

Applied with the changes below.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/services/pam-mount.scm b/gnu/services/pam-mount.scm
index 8a38d6b1cc..dbb9d0285f 100644
--- a/gnu/services/pam-mount.scm
+++ b/gnu/services/pam-mount.scm
@@ -1,5 +1,6 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2023 Brian Cully <bjc@spork.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -220,4 +221,6 @@  (define pam-mount-volume-service-type
                 (extend append)
                 (default-value '())
                 (description
-                 "Volumes to be mounted during PAM-assisted login.")))
+                 "Mount remote volumes such as CIFS shares @i{via}
+@acronym{PAM, Pluggable Authentication Modules} when logging in, using login
+credentials.")))