diff mbox series

[bug#68642] gnu: Add python-pandas-vet.

Message ID 87fryqiorz.fsf@troyfigiel.com
State New
Headers show
Series [bug#68642] gnu: Add python-pandas-vet. | expand

Commit Message

Troy Figiel Jan. 21, 2024, 5:22 p.m. UTC
* gnu/packages/python-xyz.scm (python-pandas-vet): New variable.
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: 121de47decc1029c06f6e46e5f06d7fefe8e85ec

Comments

Sharlatan Hellseher Feb. 5, 2024, 7:11 p.m. UTC | #1
Hi,

Thank you for the patch!

I started reviewing it, it looks good. I've got question on placement:
- python-science next to pandas
or
- python-check as it is related to lint

What do you think?

Regards,
Oleg
Troy Figiel Feb. 5, 2024, 9:12 p.m. UTC | #2
Hi Oleg,

Originally I put it under python-xyz, because it is a flake8 plugin and
most if not all flake8 plugins are defined in python-xyz.

It does indeed make more sense to have all flake8-related packages in
python-check instead, since it is a linting library. python-pylint is
defined under python-check for example.

For that reason, I would also advise against putting python-pandas-vet
in python-science. I leave the final placement up to you though :-)

Best wishes,

Troy
Sharlatan Hellseher Feb. 11, 2024, 9:06 p.m. UTC | #3
Hi,

I've added the package to python-check based on it's purpose.

Pushed as 579a1a8c029e97b69a7e3597ff9fd287805cf644 to master.

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b23108fbf4..dfd786e283 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13876,6 +13876,31 @@  (define-public python-flake8-isort
 directives.")
     (license license:gpl2+)))
 
+(define-public python-pandas-vet
+  (package
+    (name "python-pandas-vet")
+    ;; Newer versions require flake8>=6.0.0.
+    (version "0.2.3")
+    (source
+     (origin
+       ;; No tests in the PyPI tarball.
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/deppen8/pandas-vet")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1b3pqcargv68p2lpv72q49siq6mxfh3znxhz9vd91rp6fd6lf2cz"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-attrs python-flake8))
+    (native-inputs (list python-pytest))
+    (home-page "https://github.com/deppen8/pandas-vet")
+    (synopsis "Opionated @code{flake8} plugin for @code{pandas} code")
+    (description
+     "This package provides a @code{flake8} plugin to lint @code{pandas} code
+in an opinionated way.")
+    (license license:expat)))
+
 (define-public python-autoflake
   (package
     (name "python-autoflake")