diff mbox series

[bug#69639] gnu: Add go-github-com-alexliesenfeld-health.

Message ID 87frx0iyzk.fsf@troyfigiel.com
State New
Headers show
Series [bug#69639] gnu: Add go-github-com-alexliesenfeld-health. | expand

Commit Message

Troy Figiel March 8, 2024, 2:20 p.m. UTC
* gnu/packages/golang-web.scm (go-github-com-alexliesenfeld-health): New variable.
---
 gnu/packages/golang-web.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)


base-commit: d79c88e8809d2079452fd276bf4d17eb16636ff9

Comments

Sharlatan Hellseher March 17, 2024, 12:16 a.m. UTC | #1
Hi,

Pushed as 4a4f03ad5f43890903c149c4fb74d6dcbd7f8a35 to master.

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 1d7ad01af2..4cae5952dd 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -98,6 +98,42 @@  (define-public go-cloud-google-com-go-compute-metadata
 API service accounts for Go.")
     (license license:asl2.0)))
 
+(define-public go-github-com-alexliesenfeld-health
+  (package
+    (name "go-github-com-alexliesenfeld-health")
+    (version "0.8.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/alexliesenfeld/health")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1fchlvxwidsscskwq07vhxfwcn5wbigbizi51619l8gg09mr158q"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/alexliesenfeld/health"
+      #:phases #~(modify-phases %standard-phases
+                   (add-after 'unpack 'remove-examples
+                     (lambda* (#:key import-path #:allow-other-keys)
+                       (delete-file-recursively
+                        (string-append "src/" import-path "/examples")))))))
+    (native-inputs (list go-github-com-stretchr-testify))
+    (home-page "https://github.com/alexliesenfeld/health")
+    (synopsis "Simple and flexible health check library for Go")
+    (description
+     "This library provides a @code{http.Handler} that acts as a health
+endpoint.  It can be used by cloud infrastructure or other services to
+determine the availability of an application.
+
+Rather than simply returning a response with HTTP status code 200, this
+library allows building health checks that test the availability of all
+required dependencies.  The HTTP response contains the aggregated health
+result and details about the health status of each component.")
+    (license license:expat)))
+
 (define-public go-github-com-andybalholm-cascadia
   (package
     (name "go-github-com-andybalholm-cascadia")