diff mbox series

[bug#69711] gnu: Add go-github-com-hashicorp-go-cleanhttp.

Message ID 87frwy2i36.fsf@troyfigiel.com
State New
Headers show
Series [bug#69711] gnu: Add go-github-com-hashicorp-go-cleanhttp. | expand

Commit Message

Troy Figiel March 10, 2024, 3:37 p.m. UTC
* gnu/packages/golang-web.scm (go-github-com-hashicorp-go-cleanhttp): New variable.
---
 gnu/packages/golang-web.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)


base-commit: c7836393be4d134861d652b2fcf09cf4e68275ca

Comments

Sharlatan Hellseher March 21, 2024, 11:53 p.m. UTC | #1
Pushed as 8d27fe61d7f1a2bed0367fa861e4cae1f2f1546d to master.
diff mbox series

Patch

diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 1d7ad01af2..b9dcdd46a7 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -964,6 +964,35 @@  (define-public go-github-com-gregjones-httpcache
 shared proxy).")
       (license license:expat))))
 
+(define-public go-github-com-hashicorp-go-cleanhttp
+  (package
+    (name "go-github-com-hashicorp-go-cleanhttp")
+    (version "0.5.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/hashicorp/go-cleanhttp")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1i5xslizzwd966w81bz6dxjwzgml4q9bwqa186bsxd1vi8lqxl9p"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/hashicorp/go-cleanhttp"))
+    (home-page "https://github.com/hashicorp/go-cleanhttp")
+    (synopsis "Functions for accessing clean Go @code{http.Client} values")
+    (description
+     "The Go standard library contains a default @code{http.Client} and it is
+a common idiom to tweak it as necessary.  Unfortunately, this is a shared
+value, and it is not uncommon for libraries to assume that they are free to
+modify it at will.  This package provides some simple functions to get a
+\"clean\" @code{http.Client}, namely one that uses the same default values as
+the Go standard library, but returns a client that does not share any state
+with other clients.")
+    (license license:mpl2.0)))
+
 (define-public go-github-com-hjson-hjson-go
   (package
     (name "go-github-com-hjson-hjson-go")