[bug#74329,v3,3/8] gnu: Replace quotations with texinfo markup in Java packages.

Message ID 87frlwqldf.fsf@erlikon.ch
State New
Headers
Series None |

Commit Message

Gabriel Wicki Jan. 6, 2025, 10:17 a.m. UTC
  * gnu/packages/java-xml.scm (java-kxml2): Fix description.
* gnu/packages/java.scm (java-jsch-agentproxy-core,
java-jsch-agentproxy-sshagent, java-jsch-agentproxy-usocket-jna,
java-jsch-agentproxy-pageant, java-jsch-agentproxy-usocket-nc,
java-jsch-agentproxy-connector-factory, java-jsch-agentproxy-jsch): Fix
description.

Change-Id: I5fb17f46461f1b2a37334db2dbf1e432b8b42dae
---
 gnu/packages/java-xml.scm |  6 +++---
 gnu/packages/java.scm     | 41 ++++++++++++++++++++-------------------
 2 files changed, 24 insertions(+), 23 deletions(-)
  

Patch

diff --git a/gnu/packages/java-xml.scm b/gnu/packages/java-xml.scm
index 0153e26ef8..99b1cf47f1 100644
--- a/gnu/packages/java-xml.scm
+++ b/gnu/packages/java-xml.scm
@@ -552,9 +552,9 @@  (define-public java-kxml2
      (list java-junit))
     (home-page "http://kxml.org")
     (synopsis "XML pull parser")
-    (description "kXML is a small XML pull parser, specially designed for
-constrained environments such as Applets, Personal Java or devices compliant
-with the Mobile Information Device Profile (MIDP).")
+    (description "@emph{kXML} is a small XML pull parser, specially designed
+for constrained environments such as Applets, Personal Java or devices
+compliant with the Mobile Information Device Profile (MIDP).")
     (license license:expat)))
 
 (define-public java-stax
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 679daf6fb5..29d9cdbe33 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -13241,9 +13241,9 @@  (define-public java-jsch-agentproxy-core
        #:tests? #f)); no tests
     (home-page "https://github.com/ymnk/jsch-agent-proxy")
     (synopsis "Core component of the proxy to ssh-agent and Pageant in Java")
-    (description "jsch-agent-proxy is a proxy program to OpenSSH's ssh-agent
-and Pageant included Putty.  It will be easily integrated into JSch, and users
-will be allowed to use these programs for authentication.")
+    (description "@command{jsch-agent-proxy} is a proxy program to OpenSSH's
+ssh-agent and Pageant included Putty.  It will be easily integrated into JSch,
+and users will be allowed to use these programs for authentication.")
     (license license:bsd-3)))
 
 (define-public java-jsch-agentproxy-sshagent
@@ -13257,9 +13257,9 @@  (define-public java-jsch-agentproxy-sshagent
     (inputs
      (list java-jsch-agentproxy-core))
     (synopsis "Proxy to ssh-agent")
-    (description "jsch-agent-proxy is a proxy program to OpenSSH's ssh-agent
-and Pageant included in Putty. This component contains the code for a proxy to
-ssh-agent.")))
+    (description "@command{jsch-agent-proxy} is a proxy program to OpenSSH's
+ssh-agent and Pageant included in Putty.  This component contains the code for
+a proxy to ssh-agent.")))
 
 (define-public java-jsch-agentproxy-usocket-jna
   (package
@@ -13272,9 +13272,9 @@  (define-public java-jsch-agentproxy-usocket-jna
     (inputs
      (list java-jsch-agentproxy-core java-native-access))
     (synopsis "USocketFactory implementation using JNA")
-    (description "jsch-agent-proxy is a proxy program to OpenSSH's ssh-agent
-and Pageant included in Putty. This component contains an implementation of
-USocketFactory using @dfn{JNA} (Java Native Access).")))
+    (description "@command{jsch-agent-proxy} is a proxy program to OpenSSH's
+ssh-agent and Pageant included in Putty.  This component contains an
+implementation of USocketFactory using @dfn{JNA} (Java Native Access).")))
 
 (define-public java-jsch-agentproxy-pageant
   (package
@@ -13288,9 +13288,9 @@  (define-public java-jsch-agentproxy-pageant
      (list java-jsch-agentproxy-core java-native-access
            java-native-access-platform))
     (synopsis "Proxy to pageant")
-    (description "jsch-agent-proxy is a proxy program to OpenSSH's ssh-agent
-and Pageant included in Putty. This component contains the code for a proxy to
-pageant.")))
+    (description "@command{jsch-agent-proxy} is a proxy program to OpenSSH's
+ssh-agent and Pageant included in Putty.  This component contains the code for
+a proxy to pageant.")))
 
 (define-public java-jsch-agentproxy-usocket-nc
   (package
@@ -13303,9 +13303,9 @@  (define-public java-jsch-agentproxy-usocket-nc
     (inputs
      (list java-jsch-agentproxy-core))
     (synopsis "USocketFactory implementation using netcat")
-    (description "jsch-agent-proxy is a proxy program to OpenSSH's ssh-agent
-and Pageant included in Putty. This component contains an implementation of
-USocketFactory using netcat.")))
+    (description "@command{jsch-agent-proxy} is a proxy program to OpenSSH's
+ssh-agent and Pageant included in Putty.  This component contains an
+implementation of USocketFactory using netcat.")))
 
 (define-public java-jsch-agentproxy-connector-factory
   (package
@@ -13320,8 +13320,9 @@  (define-public java-jsch-agentproxy-connector-factory
            java-jsch-agentproxy-usocket-jna java-jsch-agentproxy-pageant
            java-jsch-agentproxy-usocket-nc))
     (synopsis "Connector factory for jsch agent proxy")
-    (description "jsch-agent-proxy is a proxy program to OpenSSH's ssh-agent
-and Pageant included in Putty. This component contains a connector factory.")))
+    (description "@command{jsch-agent-proxy} is a proxy program to OpenSSH's
+ssh-agent and Pageant included in Putty.  This component contains a connector
+factory.")))
 
 (define-public java-jsch-agentproxy-jsch
   (package
@@ -13334,9 +13335,9 @@  (define-public java-jsch-agentproxy-jsch
     (inputs
      (list java-jsch java-jsch-agentproxy-core))
     (synopsis "JSch integration library for agentproxy")
-    (description "jsch-agent-proxy is a proxy program to OpenSSH's ssh-agent
-and Pageant included in Putty. This component contains a library to use
-jsch-agent-proxy with JSch.")))
+    (description "@command{jsch-agent-proxy} is a proxy program to OpenSSH's
+ssh-agent and Pageant included in Putty.  This component contains a library to
+use jsch-agent-proxy with JSch.")))
 
 (define-public java-apache-ivy
   (package