[bug#33986,6/9] gnu: Add ocaml-migrate-parsetree.

Message ID 87ef9r8ijs.fsf@gmail.com
State Accepted
Headers show
Series [bug#33986,1/9] gnu: Add ocaml-sexplib0. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Gabriel Hondet Jan. 3, 2019, 9:40 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-migrate-parsetree): New variable.
---
 gnu/packages/ocaml.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 6f91f5d99..28ae9fd04 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5270,3 +5270,33 @@  provided by companion libraries such as
 so they don't expose everything at toplevel.  For instance, @code{Ast_helper}
 is now @code{Ocaml_common.Ast_helper}.")
     (license license:expat)))
+
+(define-public ocaml-migrate-parsetree
+  (package
+    (name "ocaml-migrate-parsetree")
+    (version "1.1.0")
+    (home-page "https://github.com/ocaml-ppx/ocaml-migrate-parsetree")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url (string-append home-page ".git"))
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1d2n349d1cqm3dr09mwy5m9rfd4bkkqvri5i94wknpsrr35vnrr1"))))
+    (build-system dune-build-system)
+    (inputs
+     `(("ocaml-compiler-libs" ,ocaml-compiler-libs)
+       ("ocaml-result" ,ocaml-result)))
+    (native-inputs
+     `(("ocamlbuild" ,ocamlbuild)))
+    (synopsis "Convert OCaml parsetrees between different major versions")
+    (description "This library converts between parsetrees of different OCaml
+version.
+
+Supported versions are 4.02, 4.03, 4.04, 4.05 and 4.06.  For each version,
+there is a snapshot of the parsetree and conversion functions to the next
+and/or previous version.")
+    (license license:lgpl2.1+)))