[bug#34139] Update electrum, add python-aiohttp-socks and python-aiorpcx

Message ID 87ef98nr6q.fsf@ponder
State Accepted
Headers show
Series [bug#34139] Update electrum, add python-aiohttp-socks and python-aiorpcx | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Vagrant Cascadian Jan. 19, 2019, 11:49 p.m. UTC
The following patches update electrum, requring updated inputs, and two
new packages, python-aiohttp-socks and python-aiorpcx.

 finance.scm    |    8 ++++++--
 python-web.scm |   45 +++++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 51 insertions(+), 2 deletions(-)

Thanks in advance for the review!

live well,
  vagrant

Comments

Ludovic Courtès Jan. 25, 2019, 9:20 p.m. UTC | #1
Hello Vagrant,

Vagrant Cascadian <vagrant@debian.org> skribis:

> The following patches update electrum, requring updated inputs, and two
> new packages, python-aiohttp-socks and python-aiorpcx.

Nipick: could you adjust the indentation of the new packages (you can
pass them through ./etc/indent-code.el if you want¹), and make sure
descriptions contain full sentences²?

With these changes we’ll be all set.  :-)

Thank you!

Ludo’.

¹ https://www.gnu.org/software/guix/manual/en/html_node/Formatting-Code.html
² https://www.gnu.org/software/guix/manual/en/html_node/Synopses-and-Descriptions.html

Patch

From 9256c2bbea5d79b2ad827f9a570932be2b38acdb Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Tue, 15 Jan 2019 04:51:34 +0000
Subject: [PATCH 3/3] gnu: electrum: Update to 3.3.2.

* gnu/packages/finance.scm (electrum): Update to 3.2.2.
  [inputs]: Add python-aiohttp, python-aiohttp-socks, python-aiorpcx and
    python-certifi.
---
 gnu/packages/finance.scm | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 468388797..293aa1f7d 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -293,7 +293,7 @@  do so.")
 (define-public electrum
   (package
     (name "electrum")
-    (version "3.2.2")
+    (version "3.3.2")
     (source
      (origin
        (method url-fetch)
@@ -302,7 +302,7 @@  do so.")
                            version ".tar.gz"))
        (sha256
         (base32
-         "1fxaxlf5vm2zydj678ls3pazyriym188iwzk60kyk26cz2p3xk39"))
+         "0vgfdhwvrrl6dr4rd4hhxr8304bxm00sh7fw4nalm4hf7gfsbcji"))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -320,6 +320,10 @@  do so.")
        ("python-requests" ,python-requests)
        ("python-qrcode" ,python-qrcode)
        ("python-protobuf" ,python-protobuf)
+       ("python-aiohttp" ,python-aiohttp)
+       ("python-aiohttp-socks" ,python-aiohttp-socks)
+       ("python-aiorpcx" ,python-aiorpcx)
+       ("python-certifi" ,python-certifi)
        ("python-dnspython" ,python-dnspython)
        ("python-jsonrpclib-pelix" ,python-jsonrpclib-pelix)))
     (arguments
-- 
2.20.1