diff mbox series

[bug#39320] gnu: Add emacs-mwim.

Message ID 87eevkhu0h.fsf@gnu.org
State Accepted
Headers show
Series [bug#39320] gnu: Add emacs-mwim. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Amin Bandali Jan. 28, 2020, 8:20 a.m. UTC
Hello,

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

[...]
>
> Thank you for the patch.
>

Cheers, and thank you for the feedback (addressed below).

>
> Is there any particular reason to prefer this particular commit over
> stable 0.4 release?
>
> If so, it may be worth mentioning as a comment.
>

The main reason is that commit is a fix for a reported issue [0], but
sadly isn’t part of any tagged release.  Further, the repository hasn’t
seen any activity in over a year, so I figured the likelihood of the
author tagging a new release any time soon is pretty slim.

[0]: https://github.com/alezost/mwim.el/issues/12

For what it’s worth, I’ve had this package definition in my personal
Guix channel for about six months now, and no activity in the upstream
repo through this time.

How does the following v2 look?
>
>
> Regards,

Best,
amin

P.S. thanks for bumping my copyright year in emacs-xyz.scm. :-)

Comments

Nicolas Goaziou Jan. 28, 2020, 9:17 a.m. UTC | #1
Amin Bandali <mab@gnu.org> writes:

> The main reason is that commit is a fix for a reported issue [0], but
> sadly isn’t part of any tagged release.  Further, the repository hasn’t
> seen any activity in over a year, so I figured the likelihood of the
> author tagging a new release any time soon is pretty slim.
>
> [0]: https://github.com/alezost/mwim.el/issues/12
>
> For what it’s worth, I’ve had this package definition in my personal
> Guix channel for about six months now, and no activity in the upstream
> repo through this time.
>
> How does the following v2 look?

Fine. I applied it as 19568f9e79ed74b7100d25d3f2ea245f857ca742. Thank
you.

Regards,
diff mbox series

Patch

From 3832e92daebd5fd1659f00179b5ad88bfd1aeef7 Mon Sep 17 00:00:00 2001
From: Amin Bandali <mab@gnu.org>
Date: Tue, 28 Jan 2020 03:18:08 -0500
Subject: [PATCH v2] gnu: Add emacs-mwim.

* gnu/packages/emacs-xyz.scm (emacs-mwim): New variable.
---
 gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ed03c2bddd..5788f57418 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21144,3 +21144,29 @@  mercury-mode provided by Emacs as a wrapper around prolog-mode.")
 EBDB.  It is copied more or less intact from @code{company-bbdb}, originally
 by Jan Tatarik.")
     (license license:gpl3+)))
+
+(define-public emacs-mwim
+  ;; Use the latest commit not in a release version as of yet, since it
+  ;; contains a bug fix for the cases where `comment-start-skip' is nil.
+  (let ((commit "b4f3edb4c0fb8f8b71cecbf8095c2c25a8ffbf85")
+        (revision "0"))
+    (package
+      (name "emacs-mwim")
+      (version (git-version "0.4" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/alezost/mwim.el.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0l3k611gp9g2x2vfmh92wnhnda81dslpwwpb8mxmzk308man77ya"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/alezost/mwim.el")
+      (synopsis "Move to the beginning/end of line, code or comment")
+      (description "@code{mwim} provides several commands to switch between
+various line positions, like moving to the beginning/end of code, line, or
+comment.")
+      (license license:gpl3+))))
-- 
2.25.0