diff mbox series

[bug#43899] gnu: emacs-counsel-projectile: Fix incompatibility.

Message ID 87eem6u1yd.fsf@odyssey.lafreniere.xyz
State Accepted
Headers show
Series [bug#43899] gnu: emacs-counsel-projectile: Fix incompatibility. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

LaFreniere, Joseph Oct. 10, 2020, 4:42 a.m. UTC
The current recipe for emacs-counsel-projectile has errors when 
paired with the current recipe of emacs-counsel.  This patch uses 
a later, untagged commit from the master branch of 
counsel-projectile that resolves the errors.

Patch file is attached.

--
Joseph LaFreniere

Comments

Nicolas Goaziou Oct. 13, 2020, 7:31 a.m. UTC | #1
Hello,

Joseph LaFreniere <joseph@lafreniere.xyz> writes:

> The current recipe for emacs-counsel-projectile has errors when paired
> with the current recipe of emacs-counsel.  This patch uses a later,
> untagged commit from the master branch of counsel-projectile that
> resolves the errors.
>
> Patch file is attached.

Thank you.

Could you add a comment explaining the above in the package definition?

Otherwise, LGTM.

Regards,
LaFreniere, Joseph Oct. 21, 2020, 8:33 p.m. UTC | #2
close 43899
quit

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:
>> The current recipe for emacs-counsel-projectile has errors when 
>> paired
>> with the current recipe of emacs-counsel.  This patch uses a 
>> later,
>> untagged commit from the master branch of counsel-projectile 
>> that
>> resolves the errors.
> Could you add a comment explaining the above in the package 
> definition?

The error that I thought was caused by an incompatibility in 
counsel-projectile seems to have actually been in ivy-rich.  I 
have opened bug#44122 to update that package instead.  This ticket 
can safely be closed.

--
Joseph LaFreniere
diff mbox series

Patch

From af4153b59d14544a4050a8da618f2cd8066c651b Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Mon, 5 Oct 2020 22:38:33 -0500
Subject: [PATCH] gnu: emacs-counsel-projectile: Fix incompatibility.

* gnu/packages/emacs-xyz.scm (emacs-counsel-projectile): Fix incompatibility
with packaged verison of emacs-counsel.
---
 gnu/packages/emacs-xyz.scm | 45 ++++++++++++++++++++------------------
 1 file changed, 24 insertions(+), 21 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 55f9f7cf4d..67cb7a0975 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7450,28 +7450,31 @@  asynchronously, with Counsel and Ivy.  Simply call
       (license license:gpl3+))))
 
 (define-public emacs-counsel-projectile
-  (package
-    (name "emacs-counsel-projectile")
-    (version "0.3.1")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/ericdanan/counsel-projectile")
-                    (commit version)))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1k4n5lw6wwbgpwv0dg9dw0bjzi0hvbgkzrs1zmq36yhfz6y8gwnh"))))
-    (build-system emacs-build-system)
-    (propagated-inputs
-     `(("emacs-counsel" ,emacs-counsel)
-       ("emacs-projectile" ,emacs-projectile)))
-    (home-page "https://github.com/ericdanan/counsel-projectile")
-    (synopsis "Enhance Projectile with Ivy")
-    (description
-     "This package uses Ivy to provide additional actions for Projectile
+  (let ((commit "77392cbbc42e98fc137b43f1db1b111ba6e2dd75")
+        (tag "0.3.1")
+        (revision "1"))
+    (package
+      (name "emacs-counsel-projectile")
+      (version (git-version tag revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/ericdanan/counsel-projectile")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "131pww7lf88az5bsnaza8i60p7xcic271wpdr870zan8z1jh69k3"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-counsel" ,emacs-counsel)
+         ("emacs-projectile" ,emacs-projectile)))
+      (home-page "https://github.com/ericdanan/counsel-projectile")
+      (synopsis "Enhance Projectile with Ivy")
+      (description
+       "This package uses Ivy to provide additional actions for Projectile
 commands and replacements for existing functions.")
-    (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public emacs-qml-mode
   (package
-- 
2.28.0