diff mbox series

[bug#44024] gnu: emacs-request: Update to latest commit.

Message ID 87eekpwwnf.fsf@posteo.net
State Accepted
Headers show
Series [bug#44024] gnu: emacs-request: Update to latest commit. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Niklas Eklund Nov. 19, 2020, 8:58 a.m. UTC
Ludovic Courtès <ludo@gnu.org> writes:

> Hi,
>
>> +(define-public emacs-gcmh
>> +  (let ((commit "84c43a4c0b41a595ac6e299fa317d2831813e580")
>> +        (revision "0"))
>
> Looks like you forgot the comment.  :-)
>
> Could you send an updated patch?  (Else we can do it for you.)

>
> Thanks,
> Ludo’.

Hi Ludo,

I could have sworn I updated that, must be something that I have done
wrong here :O.

I will make a new atempt, in this message attaching a new patch. If that
still fails feel free to make the change :)
Thanks,
Niklas

Comments

Nicolas Goaziou Nov. 19, 2020, 8:28 p.m. UTC | #1
Hello,

Niklas Eklund <niklas.eklund@posteo.net> writes:

> * gnu/packages/emacs-xyz.scm (emacs-request): Update to latest commit.

Applied. Thank you.

Regards,
diff mbox series

Patch

From 75bfe74c5e150b5aca294c7b51e94d63b188dbe7 Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Thu, 15 Oct 2020 22:23:58 +0200
Subject: [PATCH v3] gnu: emacs-request: Update to latest commit.

* gnu/packages/emacs-xyz.scm (emacs-request): Update to latest commit.
---
 gnu/packages/emacs-xyz.scm | 46 +++++++++++++++++++++-----------------
 1 file changed, 25 insertions(+), 21 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 09984bc704..e88119ea43 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6910,29 +6910,33 @@  parallel.")
     (license license:gpl3+)))
 
 (define-public emacs-request
-  (package
-    (name "emacs-request")
-    (version "0.3.2")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/tkf/emacs-request")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1djywhvvb6kwdj0nd3axjvb7k2g06dzkc6hsf29w9rsk96vr8ryl"))))
-    (build-system emacs-build-system)
-    (arguments
-     `(#:tests? #f)) ; requires network access.
-    (propagated-inputs
-     `(("emacs-deferred" ,emacs-deferred)))
-    (home-page "https://github.com/tkf/emacs-request")
-    (synopsis "Package for speaking HTTP in Emacs Lisp")
-    (description "This package provides a HTTP request library with multiple
+  ;; We prefer a more recent commit that has support for auth-source,
+  ;; which makes authentication more convenient for users and maintainers.
+  (let ((commit "d02d1347ffdf138cffd380cbeac62ac8732036ef")
+        (revision "0"))
+    (package
+      (name "emacs-request")
+      (version (git-version "0.3.2" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/tkf/emacs-request")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1rkpakzish2d470ca15yq3k0m1j7a2lrkvvddcyvc2rx0sncsdjs"))))
+      (build-system emacs-build-system)
+      (arguments
+       `(#:tests? #f))                  ; requires network access.
+      (propagated-inputs
+       `(("emacs-deferred" ,emacs-deferred)))
+      (home-page "https://github.com/tkf/emacs-request")
+      (synopsis "Package for speaking HTTP in Emacs Lisp")
+      (description "This package provides a HTTP request library with multiple
 backends.  It supports url.el which is shipped with Emacs and the curl command
 line program.")
-    (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public emacs-rudel
   (package
-- 
2.28.0