diff mbox series

[bug#50332] home-services: Add Shepherd.

Message ID 87eea22i9u.fsf@trop.in
State Accepted
Headers show
Series [bug#50332] home-services: Add Shepherd. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Andrew Tropin Sept. 6, 2021, 8:57 a.m. UTC
On 2021-09-03 14:03, Oleg Pykhalov wrote:

> Andrew Tropin <andrew@trop.in> writes:
>
>>>> * gnu/home-services/shepherd.scm: New file.
>>>> * doc/guix.texi: Add documentation about Shepherd Home Service.
>>>> ---
>>>>  doc/guix.texi                  |  31 +++++++-
>>>>  gnu/home-services/shepherd.scm | 133 +++++++++++++++++++++++++++++++++
>
> Added to gnu/local.mk.
>
> Pushed to wip-guix-home.

Thank you!

After Maxime's message, I decided to remove G_ from G-expression, which
get serialized to shepherd.conf, please, add this patch to wip-guix-home
too:

Comments

Oleg Pykhalov Sept. 6, 2021, 11:22 a.m. UTC | #1
Andrew Tropin <andrew@trop.in> writes:

[…]

> After Maxime's message, I decided to remove G_ from G-expression, which
> get serialized to shepherd.conf, please, add this patch to wip-guix-home
> too:
>
> From 066d31f7a1cc69c84d2009cd67dfda8eca693b4c Mon Sep 17 00:00:00 2001
> From: Andrew Tropin <andrew@trop.in>
> Date: Mon, 6 Sep 2021 11:50:57 +0300
> Subject: [PATCH] home-services: shepherd: Remove G_ from shepherd.conf's G-exp
>
> * gnu/home-services/shepherd.scm: Remove G_ from shepherd.conf.
> ---
>  gnu/home-services/shepherd.scm | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)

OK, Pushed.
diff mbox series

Patch

From 066d31f7a1cc69c84d2009cd67dfda8eca693b4c Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Mon, 6 Sep 2021 11:50:57 +0300
Subject: [PATCH] home-services: shepherd: Remove G_ from shepherd.conf's G-exp

* gnu/home-services/shepherd.scm: Remove G_ from shepherd.conf.
---
 gnu/home-services/shepherd.scm | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/gnu/home-services/shepherd.scm b/gnu/home-services/shepherd.scm
index 04366f4b81..b9fd3c367b 100644
--- a/gnu/home-services/shepherd.scm
+++ b/gnu/home-services/shepherd.scm
@@ -23,7 +23,6 @@ 
   #:use-module (gnu services shepherd)
   #:use-module (guix sets)
   #:use-module (guix gexp)
-  #:use-module (guix i18n)
   #:use-module (guix records)
 
   #:use-module (srfi srfi-1)
@@ -61,7 +60,7 @@  as shepherd package."
             (lambda (file) (load file))
             '#$files))
           (action 'root 'daemonize)
-          (format #t (G_ "Starting services...~%"))
+          (format #t "Starting services...~%")
           (for-each
            (lambda (service) (start service))
            '#$(append-map shepherd-service-provision
-- 
2.33.0