diff mbox series

[bug#51980] Adding xlispstat.scm

Message ID 87ee79cj0j.fsf@fpp-Latitude-7280.i-did-not-set--mail-host-address--so-tickle-me
State Accepted
Headers show
Series [bug#51980] Adding xlispstat.scm | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Frank Pursel Nov. 21, 2021, 9:10 p.m. UTC
From d39e627c9433e3193de1857a9c0f5b438082ba3f Mon Sep 17 00:00:00 2001
From: Frank Pursel <frank.pursel@gmail.com>
Date: Sun, 21 Nov 2021 09:29:18 -0800
Subject: [PATCH] Adding xlispstat

---
 gnu/packages/statistics.scm | 50 +++++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)

Comments

Liliana Marie Prikler Nov. 22, 2021, 8:39 p.m. UTC | #1
Pushed with the following adjustments:

Am Sonntag, den 21.11.2021, 13:10 -0800 schrieb Frank Pursel:
> From d39e627c9433e3193de1857a9c0f5b438082ba3f Mon Sep 17 00:00:00
> 2001
> From: Frank Pursel <frank.pursel@gmail.com>
> Date: Sun, 21 Nov 2021 09:29:18 -0800
> Subject: [PATCH] Adding xlispstat
> 
> ---
Added a commit message.
>  gnu/packages/statistics.scm | 50
> +++++++++++++++++++++++++++++++++++++
>  1 file changed, 50 insertions(+)
> 
> diff --git a/gnu/packages/statistics.scm
> b/gnu/packages/statistics.scm
> index e69baee8bd..36d1030bc6 100644
> --- a/gnu/packages/statistics.scm
> +++ b/gnu/packages/statistics.scm
> @@ -14,6 +14,7 @@
>  ;;; Copyright © 2020 Tim Howes <timhowes@lavabit.com>
>  ;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com
> >
>  ;;; Copyright © 2021 Lars-Dominik Braun <lars@6xq.net>
> +;;; Copyright © 2021 Frank Pursel <frank.pursel@gmail.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -67,6 +68,7 @@ (define-module (gnu packages statistics)
>    #:use-module (gnu packages machine-learning)
>    #:use-module (gnu packages maths)
>    #:use-module (gnu packages multiprecision)
> +  #:use-module (gnu packages ncurses)
>    #:use-module (gnu packages pcre)
>    #:use-module (gnu packages perl)
>    #:use-module (gnu packages pkg-config)
> @@ -74,6 +76,7 @@ (define-module (gnu packages statistics)
>    #:use-module (gnu packages python-science)
>    #:use-module (gnu packages python-xyz)
>    #:use-module (gnu packages readline)
> +  #:use-module (gnu packages shells)
>    #:use-module (gnu packages sphinx)
>    #:use-module (gnu packages ssh)
>    #:use-module (gnu packages tcl)
> @@ -6830,3 +6833,50 @@ (define-public r-desctools
>  from contributed R packages as well.")
>      (license license:gpl2+)))
>  
> +(define-public xlispstat
> +  (let ((xlispstat-version "3.52.23")
> +	(guix-revision "0")
> +	(commit "f1bea6053df658ee48612bf1f63c35de99e2c649"))
> +  (package
> +   (name "xlispstat")
> +   (version (git-version xlispstat-version guix-revision commit))
> +   (source (origin
> +	    (method git-fetch)
> +	    (uri (git-reference
> +		  (url "https://github.com/jhbadger/xlispstat.git")
> +		  (commit commit)))
> +	    (sha256
> +	     (base32
> +	      "1p0cmgy19kbkxia139cb5w9dnkp2cdqp5n3baag6cq3prn3n71mf")))
> )
> +   (build-system gnu-build-system)
> +   (arguments
> +    `(#:parallel-build? #f   ; Parallel builds are not supported
> +      #:parallel-tests? #f   
> +      #:tests? #f            ; Pre-integrated testing source code.
> +      #:configure-flags
> +      (list "--with-gcc")))
Enabled tests.
> +   (inputs `(("tcsh" ,tcsh)
> +	     ("libx11" ,libx11)
> +	     ("libxmu" ,libxmu)
> +	     ("libxext" ,libxext)
> +	     ("libxpm" ,libxpm)
> +	     ("libxaw" ,libxaw)
> +	     ("ncurses" ,ncurses)
> +	     ("gnuplot" ,gnuplot)))
> +   (native-inputs `(("pkg-config" ,pkg-config)))
> +   (synopsis "Statistical analysis environment with interactive
> graphics based on lisp")
> +   (description "XLISP-STAT is a statistical environment based on a
> dialect of the Lisp language called XLISP.  To facilitate statistical
> +computations, standard Lisp functions for addition, logarithms,
> etc.,
> +have been modified to operate on lists and arrays of numbers, and a
> +number of basic statistical functions have been added.  Many of
> these
> +functions have been written in Lisp, and additional functions can be
> +added easily by a user.  Several basic forms of plots, including
> +histograms, scatterplots, rotatable plots and scatterplot matrices
> are
> +provided.  These plots support various forms of interactive
> +highlighting operations and can be linked so points highlighted in
> one
> +plot will be highlighted in all linked plots. Interactions with the
> +plots are controlled by the mouse, menus and dialog boxes. An
> +object-oriented programming system is used to allow menus, dialogs,
> +and the response to mouse actions to be customized.")
Fixed indentation + minor wording.
> +   (home-page "http://homepage.divms.uiowa.edu/~luke/xls/xlsinfo/")
> +   (license expat))))
Used license:expat
diff mbox series

Patch

diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index e69baee8bd..36d1030bc6 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -14,6 +14,7 @@ 
 ;;; Copyright © 2020 Tim Howes <timhowes@lavabit.com>
 ;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
 ;;; Copyright © 2021 Lars-Dominik Braun <lars@6xq.net>
+;;; Copyright © 2021 Frank Pursel <frank.pursel@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -67,6 +68,7 @@  (define-module (gnu packages statistics)
   #:use-module (gnu packages machine-learning)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages multiprecision)
+  #:use-module (gnu packages ncurses)
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
@@ -74,6 +76,7 @@  (define-module (gnu packages statistics)
   #:use-module (gnu packages python-science)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages readline)
+  #:use-module (gnu packages shells)
   #:use-module (gnu packages sphinx)
   #:use-module (gnu packages ssh)
   #:use-module (gnu packages tcl)
@@ -6830,3 +6833,50 @@  (define-public r-desctools
 from contributed R packages as well.")
     (license license:gpl2+)))
 
+(define-public xlispstat
+  (let ((xlispstat-version "3.52.23")
+	(guix-revision "0")
+	(commit "f1bea6053df658ee48612bf1f63c35de99e2c649"))
+  (package
+   (name "xlispstat")
+   (version (git-version xlispstat-version guix-revision commit))
+   (source (origin
+	    (method git-fetch)
+	    (uri (git-reference
+		  (url "https://github.com/jhbadger/xlispstat.git")
+		  (commit commit)))
+	    (sha256
+	     (base32
+	      "1p0cmgy19kbkxia139cb5w9dnkp2cdqp5n3baag6cq3prn3n71mf"))))
+   (build-system gnu-build-system)
+   (arguments
+    `(#:parallel-build? #f   ; Parallel builds are not supported
+      #:parallel-tests? #f   
+      #:tests? #f            ; Pre-integrated testing source code.
+      #:configure-flags
+      (list "--with-gcc")))
+   (inputs `(("tcsh" ,tcsh)
+	     ("libx11" ,libx11)
+	     ("libxmu" ,libxmu)
+	     ("libxext" ,libxext)
+	     ("libxpm" ,libxpm)
+	     ("libxaw" ,libxaw)
+	     ("ncurses" ,ncurses)
+	     ("gnuplot" ,gnuplot)))
+   (native-inputs `(("pkg-config" ,pkg-config)))
+   (synopsis "Statistical analysis environment with interactive graphics based on lisp")
+   (description "XLISP-STAT is a statistical environment based on a dialect of the Lisp language called XLISP.  To facilitate statistical
+computations, standard Lisp functions for addition, logarithms, etc.,
+have been modified to operate on lists and arrays of numbers, and a
+number of basic statistical functions have been added.  Many of these
+functions have been written in Lisp, and additional functions can be
+added easily by a user.  Several basic forms of plots, including
+histograms, scatterplots, rotatable plots and scatterplot matrices are
+provided.  These plots support various forms of interactive
+highlighting operations and can be linked so points highlighted in one
+plot will be highlighted in all linked plots. Interactions with the
+plots are controlled by the mouse, menus and dialog boxes. An
+object-oriented programming system is used to allow menus, dialogs,
+and the response to mouse actions to be customized.")
+   (home-page "http://homepage.divms.uiowa.edu/~luke/xls/xlsinfo/")
+   (license expat))))