diff mbox series

[bug#55731] gnu: Add python-musical-scales

Message ID 87ee0azt62.fsf@gmail.com
State Accepted
Headers show
Series [bug#55731] gnu: Add python-musical-scales | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Artyom V. Poptsov May 30, 2022, 8:01 p.m. UTC
Hello,

this patch adds "musical-scales" Python module[1] under the name
"python-musical-scales".

References:
1. "Retrieve a scale based on a given mode and starting note."
   https://github.com/hmillerbakewell/musical-scales

Comments

Mathieu Othacehe June 5, 2022, 6:50 p.m. UTC | #1
Hello Artyom,

> +    (inputs (list python))

I removed this implicit line and pushed.

Thanks,

Mathieu
diff mbox series

Patch

From bdd66c0ec7cb5d19f6210cbda3b1d465322a7864 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Mon, 30 May 2022 22:57:49 +0300
Subject: [PATCH] gnu: Add python-musical-scales

* gnu/packages/python-xyz.scm (python-musical-scales): New variable.
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index acd5954fb6..1f106d0075 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31838,3 +31838,25 @@  profile.  It supports:
 
 Currently, Linux is the only platform supported by this library.")
     (license license:expat)))
+
+(define-public python-musical-scales
+  (package
+    (name "python-musical-scales")
+    (version "1.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "musical-scales" version))
+              (sha256
+               (base32
+                "1ckn8n37i7b65h0i385ycn0w8sg9na0iabz0kmhxxc1wj0hddkw9"))))
+    (build-system python-build-system)
+    (native-inputs (list python-wheel))
+    (inputs (list python))
+    (home-page "https://github.com/hmillerbakewell/musical-scales")
+    (synopsis "Retrieve a scale based on a given mode and starting note")
+    (description
+     "Retrieve a scale based on a given mode and starting note.
+Information about these scales can be
+@url{https://en.wikipedia.org/wiki/List_of_musical_scales_and_modes, found on
+Wikipedia}.")
+    (license license:expat)))
-- 
2.25.1