diff mbox series

bug#55935: [PATCH 1/1] gnu: Add casacore

Message ID 87edzfvzzj.fsf@gnu.org
State Accepted
Headers show
Series bug#55935: [PATCH 1/1] gnu: Add casacore | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ludovic Courtès June 23, 2022, 9:20 p.m. UTC
Hi,

Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

> From 916bde255b94eab85c10e55104b0e088781ef943 Mon Sep 17 00:00:00 2001
> From: Sharlatan Hellseher <sharlatanus@gmail.com>
> Date: Sun, 12 Jun 2022 22:25:07 +0100
> Subject: [PATCH 1/1] gnu: Add casacore
>
> * gnu/packages/astronomy.scm (casacore): New variable.
>   Modules sorted alphabetically to easy maintannce.
> ---
>  gnu/packages/astronomy.scm | 102 +++++++++++++++++++++++++++++++++++--
>  1 file changed, 97 insertions(+), 5 deletions(-)

Applied with the changes below:

  • use ‘this-package-input’ to refer to the same Python package that
    appears in ‘inputs’;

  • use ‘search-input-file’ rather than ‘which’ for “rm”, which is more
    correct if we ever want to cross-compile it (it makes sure we pick
    “rm” among the inputs rather than among native inputs);

  • remove now-unneeded trailing #t from build phases;

  • change license to ‘gpl2+’ because source file headers explicitly say
    “or any later version”.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index a0de5a617f..61c10c985f 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -130,11 +130,11 @@  (define-public casacore
     (build-system cmake-build-system)
     (arguments
      (list
-      ;; NOTE: (Sharlatan-20220611T213043+0100): There are multiple fails in
+      ;; Note: There are multiple failures in
       ;; tests which require additional measures data. They are
       ;; distributed via FTP without any license:
       ;; ftp://ftp.astron.nl/outgoing/Measures/
-      ;; Check how to fix tests.
+      ;; TODO: Check how to fix tests.
       #:tests? #f
       #:parallel-build? #t
       #:configure-flags
@@ -145,25 +145,27 @@  (define-public casacore
               "-DUSE_OPENMP=OFF"
               "-DUSE_THREADS=ON"
               (string-append "-DDATA_DIR=" #$output "/data")
-              (string-append "-DPYTHON3_EXECUTABLE=" #$python "/bin")
-              (string-append "-DPYTHON3_INCLUDE_DIR=" #$python "/include")
-              (string-append "-DPYTHON3_LIBRARY=" #$python "/lib"))
+              (string-append "-DPYTHON3_EXECUTABLE="
+                             #$(this-package-input "python") "/bin")
+              (string-append "-DPYTHON3_INCLUDE_DIR="
+                             #$(this-package-input "python") "/include")
+              (string-append "-DPYTHON3_LIBRARY="
+                             #$(this-package-input "python") "/lib"))
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'set-env
             (lambda _
               (setenv "HOME" "/tmp")))
           (add-after 'unpack 'use-absolute-rm
-            (lambda _
+            (lambda* (#:key inputs #:allow-other-keys)
               (substitute* "casa/OS/test/tFile.run"
-                (("/bin/rm") (which "rm")))
-              #t))
+                (("/bin/rm")
+                 (search-input-file inputs "/bin/rm")))))
           (add-after 'unpack 'use-absolute-python3
             (lambda _
               (substitute* "build-tools/casacore_floatcheck"
                 (("#!/usr/bin/env python")
-                 (string-append "#!" #$python "/bin/python3")))
-              #t))
+                 (string-append "#!" (which "python3"))))))
           ;; NOTE: (Sharlatan-20220611T200837+0100): Workaround for casacore
           ;; tests stuck with missing "qsub" issue.
           ;; https://github.com/casacore/casacore/issues/1122
@@ -171,8 +173,7 @@  (define-public casacore
             (lambda _
               (substitute* "build-tools/casacore_assay"
                 (("QSUBP=.*$") "QSUBP=\n")
-                (("YODP=.*$") "YODP=\n"))
-              #t)))))
+                (("YODP=.*$") "YODP=\n")))))))
     (native-inputs
      (list bison
            boost
@@ -194,10 +195,10 @@  (define-public casacore
     (synopsis "Suite of C++ libraries for radio astronomy data processing")
     (description
      "The casacore package contains the core libraries of the old
-@code{AIPS++/CASA} (Common Astronomy Software Application) package.  This split
-was made to get a better separation of core libraries and applications.
-(CASA @url{https://casa.nrao.edu/}) is now built on top of Casacore.")
-    (license license:gpl2)))
+AIPS++/CASA (Common Astronomy Software Application) package.  This split was
+made to get a better separation of core libraries and applications.
+@url{https://casa.nrao.edu/, CASA} is now built on top of Casacore.")
+    (license license:gpl2+)))
 
 (define-public cfitsio
   (package