diff mbox series

[bug#64641] gnu: Add emacs-speed-type.

Message ID 87edl9wt33.fsf@disroot.org
State New
Headers show
Series [bug#64641] gnu: Add emacs-speed-type. | expand

Commit Message

Abhiseck Paira July 15, 2023, 6:31 a.m. UTC
From 37861dd8272fae95d35573a627802fed1dca7c93 Mon Sep 17 00:00:00 2001
From: Abhiseck Paira <abhiseckpaira@disroot.org>

* gnu/packages/emacs-xyz.scm (emacs-speed-type): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: f0ca6346a46c605a590bfd77b84e143a8c759a3b

Comments

Nicolas Goaziou Sept. 2, 2023, 9:55 p.m. UTC | #1
Hello,

Abhiseck Paira via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-speed-type): New variable.

Applied, with the changes noted below. Thank you!

> +(define-public emacs-speed-type
> +  (package
> +    (name "emacs-speed-type")
> +    (version "20230206.1330")

This version number is specific to MELPA, but does not correspond to
real upstream version. In this case, I changed it to "1.3".

> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append "https://melpa.org/packages/" "speed-type-"
> +                                  version ".tar"))

We don't use MELPA as source because the tarballs they produce are not
stable. I used GitHub repository instead.


Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index be4e7aa78e..9f3e91c39f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1920,6 +1920,28 @@  (define-public emacs-typing
 you will die.  The game builds the list of words from the active buffer.")
       (license license:gpl2+))))
 
+(define-public emacs-speed-type
+  (package
+    (name "emacs-speed-type")
+    (version "20230206.1330")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://melpa.org/packages/" "speed-type-"
+                                  version ".tar"))
+              (sha256
+               (base32
+                "07xmkjhd4s0ajb8i47rx4s0j0f0y9w4k93zy57wq0sga4xgf3bkv"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-compat))
+    (home-page "https://github.com/dakra/speed-type")
+    (synopsis "Practice touch/speed typing in GNU Emacs.")
+    (description
+     "Speed-type allows you to practice your touch typing skills.  You can
+test yourself by typing snippets from online books or use any piece of text or
+code you have in Emacs.  Speed-type keeps track of your stats (WPM, CPM,
+accuracy) while you are typing.")
+    (license license:gpl3+)))
+
 (define-public emacs-graphql
   (let ((commit "b57b5ca5d2d0837e1fb4a4f30c051d5f3e643f0f")) ;version bump
     (package