diff mbox series

bug#65932: [PATCH] gnu: Add blinkenlights.

Message ID 87edij1dog.fsf@gnu.org
State New
Headers show
Series bug#65932: [PATCH] gnu: Add blinkenlights. | expand

Commit Message

Ludovic Courtès Sept. 27, 2023, 9:58 p.m. UTC
"B. Wilson" <elaexuotee@wilsonb.com> skribis:

> * gnu/packages/assembly.scm (blinkenlights): New variable.

Applied with the cosmetic changes below.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 7ea8712e60..3bfe0bd3e0 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -650,19 +650,18 @@  (define-public blinkenlights
   (package
     (name "blinkenlights")
     (version "1.0.0")
-    (source
-      (origin
+    (source (origin
               (method git-fetch)
               (uri (git-reference
-               (url "https://github.com/jart/blink.git")
+                    (url "https://github.com/jart/blink")
                     (commit version)))
               (sha256
-          (base32 "0dgfqy5z1vbpgbf39f14ngkqmw4gi3hsyihi4sh1qcbp9gnqpg2v"))
+               (base32
+                "0dgfqy5z1vbpgbf39f14ngkqmw4gi3hsyihi4sh1qcbp9gnqpg2v"))
               (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (arguments
-      (list
-        #:tests? #f  ; Tests require network access
+     (list #:tests? #f                           ;Tests require network access
            #:phases
            #~(modify-phases %standard-phases
                ;; Call ./configure without --enable-fast-install argument, which
@@ -671,11 +670,12 @@  (define-public blinkenlights
                  (lambda* (#:key inputs outputs #:allow-other-keys)
                    (invoke "./configure"
                            (string-append "CC=" #$(cc-for-target))
-                      (string-append "--prefix=" (assoc-ref outputs "out"))))))))
+                           (string-append "--prefix="
+                                          (assoc-ref outputs "out"))))))))
     (home-page "https://justine.lol/blinkenlights/")
-    (synopsis "TUI emulator for x86-64-linux programs")
-    (description "Blinkenlights is a command line debugger that focuses on
-visualizing how software changes memory.  It's able to emulate statically
-linked i8086 and x86_64-pc-linux-gnu programs on the Linux, Mac, Windows,
-FreeBSD, NetBSD, and OpenBSD platforms.")
+    (synopsis "Emulator for x86_64-linux programs with a text user interface")
+    (description
+     "Blinkenlights is a command-line debugger that focuses on visualizing how
+software changes memory.  It can emulate statically-linked i8086 and
+x86_64-pc-linux-gnu programs.")
     (license license:isc)))