diff mbox series

[bug#68326] gnu: Add rust-hexf-parse-0.2.

Message ID 87ederiyoj.fsf@troyfigiel.com
State New
Headers show
Series [bug#68326] gnu: Add rust-hexf-parse-0.2. | expand

Commit Message

Troy Figiel Jan. 8, 2024, 4:19 p.m. UTC
* gnu/packages/crates-io.scm (rust-hexf-parse-0.2): New variable.
---
 gnu/packages/crates-io.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)


base-commit: 5f8a993aa85554ca09bd27139230d7664107e1b6

Comments

Efraim Flashner Jan. 19, 2024, 9:38 a.m. UTC | #1
Thanks. Patch pushed to the rust-team branch
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1bfd8fb143..0806a18b88 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -35213,6 +35213,25 @@  (define-public rust-hex-literal-impl-0.1
      `(#:cargo-inputs
        (("rust-proc-macro-hack" ,rust-proc-macro-hack-0.4))))))
 
+(define-public rust-hexf-parse-0.2
+  (package
+    (name "rust-hexf-parse")
+    (version "0.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "hexf-parse" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1pr3a3sk66ddxdyxdxac7q6qaqjcn28v0njy22ghdpfn78l8d9nz"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/lifthrasiir/hexf")
+    (synopsis "Hexadecimal float support for Rust")
+    (description "This library provides parsing functionality for hexadecimal
+float literals.  Two functions @code{parse_hexf32} and @code{parse_hexf64} are
+provided for each type.")
+    (license license:cc0)))
+
 (define-public rust-hkdf-0.12
   (package
     (name "rust-hkdf")