diff mbox series

[bug#69713] gnu: Add go-github-com-hashicorp-go-hclog.

Message ID 87edci2aq4.fsf@troyfigiel.com
State New
Headers show
Series [bug#69713] gnu: Add go-github-com-hashicorp-go-hclog. | expand

Commit Message

Troy Figiel March 10, 2024, 6:35 p.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-hashicorp-go-hclog): New variable.
---
 gnu/packages/golang-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)


base-commit: c7836393be4d134861d652b2fcf09cf4e68275ca

Comments

Sharlatan Hellseher March 21, 2024, 11:54 p.m. UTC | #1
Pushed as 27b339702f601d2635416111930843a32dd625ed to master.
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0b3db6e379..b7572c0cc7 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -853,6 +853,38 @@  (define-public go-github-com-hashicorp-hcl-v2
     (home-page "https://github.com/hashicorp/hcl")
     (license license:mpl2.0)))
 
+(define-public go-github-com-hashicorp-go-hclog
+  (package
+    (name "go-github-com-hashicorp-go-hclog")
+    (version "1.6.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/hashicorp/go-hclog")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1lvr4ga95a0xb62vgq1hy558x3r65hn2d0h7bf0a88lsfsrcik0n"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/hashicorp/go-hclog"))
+    (propagated-inputs (list go-github-com-fatih-color
+                             go-github-com-mattn-go-isatty
+                             go-golang-org-x-tools))
+    (native-inputs (list go-github-com-stretchr-testify))
+    (home-page "https://github.com/hashicorp/go-hclog")
+    (synopsis "Key/value logging interface for Go")
+    (description
+     "This package provides a simple key/value logging interface for Golang
+for use in development and production environments.  Unlike the standard
+library @code{log} package, this package provides logging levels that provide
+decreased output based upon the desired amount of output.  It also comes with
+a command-line program @code{hclogvet} that can be used to check that the logging level
+methods on @code{hclog.Logger} are used correctly.")
+    (license license:expat)))
+
 (define-public go-github-com-hashicorp-go-multierror
   (package
     (name "go-github-com-hashicorp-go-multierror")