diff mbox series

bug#69970: [PATCH] gnu: gerbil: Update to 0.18.1.

Message ID 87edbsfv4p.fsf@gnu.org
State New
Headers show
Series bug#69970: [PATCH] gnu: gerbil: Update to 0.18.1. | expand

Commit Message

Ludovic Courtès March 29, 2024, 11:58 p.m. UTC
Hi,

Skylar Hill <stellarskylark@posteo.net> skribis:

>>From 0fd3c8a884393951a4d73ca54aaad278e5c4495f Mon Sep 17 00:00:00 2001
> Message-ID: <0fd3c8a884393951a4d73ca54aaad278e5c4495f.1711243058.git.stellarskylark@posteo.net>
> From: Skylar Hill <stellarskylark@posteo.net>
> Date: Sat, 23 Mar 2024 19:50:40 -0500
> Subject: [PATCH] gnu: gerbil: Update to 0.18.1.
>
> * gnu/packages/scheme.scm (gerbil): Update to 0.18.1.
>
> Upstream follows the standard autotools build system more closely now, which
> simplifies the package definition a lot.
>
> Change-Id: I4248ae3d6df3beaf57b6036f5329374da79e26f1

Applied with the changes below and a more detailed commit log.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 36f6d84485..070696d6ba 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -1133,8 +1133,7 @@  (define-public gerbil
                    (delete 'bootstrap)
                    (add-after 'set-paths 'set-cc
                      (lambda _
-                       (setenv "CC"
-                               (string-append #$gcc "/bin/gcc"))))
+                       (setenv "CC" #$(cc-for-target))))
                    (add-before 'patch-generated-file-shebangs 'fix-gxi-shebangs
                      (lambda _
                        ;; Some .ss files refer to gxi using /usr/bin/env gxi
@@ -1184,7 +1183,7 @@  (define-public gerbil
                         "-qefc"
                         "./build.sh"))))
       #:tests? #f))
-    (native-inputs (list coreutils gcc gambit-c util-linux))
+    (native-inputs (list gambit-c util-linux))
     (propagated-inputs (list gambit-c openssl sqlite zlib))
     (build-system gnu-build-system)
     (synopsis "Meta-dialect of Scheme with post-modern features")