diff mbox series

[bug#69880] gnu: pciutils: Update hwdata to 0.380.

Message ID 87e739be720e900d44f574522e478c4a@lyrion.ch
State New
Headers show
Series [bug#69880] gnu: pciutils: Update hwdata to 0.380. | expand

Commit Message

Daniel Ziltener March 18, 2024, 10:09 p.m. UTC
---
 gnu/packages/pciutils.scm | 70 ++++++++++++++++++++-------------------
 1 file changed, 36 insertions(+), 34 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/pciutils.scm b/gnu/packages/pciutils.scm
index 140bbd0e90..b4ec295978 100644
--- a/gnu/packages/pciutils.scm
+++ b/gnu/packages/pciutils.scm
@@ -38,44 +38,46 @@  (define-module (gnu packages pciutils)
 
 (define-public hwdata
   (package
-    (name "hwdata")
-    (version "0.365")                   ;updated monthly
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/vcrhonek/hwdata")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "00gqx24dyy9l98ygnvx8i087xq8pl9d2393h4d2cm4d5nnvr51d4"))))
-    (build-system gnu-build-system)
-    (outputs '("out" "iab" "oui" "pci" "pnp" "usb"))
-    (arguments
-     ;; Tests require pciutils, python, podman. Disable to avoid recursive dep.
-     (list
-      #:tests? #f
-      ;; Do not cross-compile, since the package only contains data.
-      #:target #f
-      #:configure-flags #~(list (string-append "--datadir=" #$output "/share"))
-      #:phases
-      #~(modify-phases %standard-phases
-          (replace 'install
-            (lambda _
-              (install-file "iab.txt" (string-append #$output:iab "/share/hwdata"))
-              (install-file "oui.txt" (string-append #$output:oui "/share/hwdata"))
-              (install-file "pci.ids" (string-append #$output:pci "/share/hwdata"))
-              (install-file "pnp.ids" (string-append #$output:pnp "/share/hwdata"))
-              (install-file "usb.ids" (string-append #$output:usb "/share/hwdata")))))))
-    (home-page "https://github.com/vcrhonek/hwdata")
-    (synopsis "Hardware identification and configuration data")
-    (description "@code{hwdata} contains various hardware identification and
+   (name "hwdata")
+   (version "0.380")                    ;updated monthly
+   (source (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (url "https://github.com/vcrhonek/hwdata")
+                  (commit (string-append "v" version))))
+            (file-name (git-file-name name version))
+            (sha256
+             (base32
+              "1j7lr67ay4nz737cv4y1hiyqdz03zl5c1vdavr7fd05h92sv91i2"))))
+   (build-system gnu-build-system)
+   (native-inputs
+    (list pkg-config))
+   (outputs '("out" "iab" "oui" "pci" "pnp" "usb"))
+   (arguments
+    ;; Tests require pciutils, python, podman. Disable to avoid recursive dep.
+    (list
+     #:tests? #f
+     ;; Do not cross-compile, since the package only contains data.
+     #:target #f
+     #:configure-flags #~(list (string-append "--datadir=" #$output "/share"))
+     #:phases
+     #~(modify-phases %standard-phases
+                      (add-after 'install 'post-install
+                                 (lambda _
+                                   (install-file "iab.txt" (string-append #$output:iab "/share/hwdata"))
+                                   (install-file "oui.txt" (string-append #$output:oui "/share/hwdata"))
+                                   (install-file "pci.ids" (string-append #$output:pci "/share/hwdata"))
+                                   (install-file "pnp.ids" (string-append #$output:pnp "/share/hwdata"))
+                                   (install-file "usb.ids" (string-append #$output:usb "/share/hwdata")))))))
+   (home-page "https://github.com/vcrhonek/hwdata")
+   (synopsis "Hardware identification and configuration data")
+   (description "@code{hwdata} contains various hardware identification and
 configuration data, such as the @file{pci.ids} and @file{usb.ids} databases.
 Each database is contained in a specific package output, such as the
 @code{pci} output for @file{pci.ids}, the @code{usb} output for
 @file{usb.ids}, etc.")
-    (license (list license:gpl2+
-                   license:expat)))) ;XFree86 1.0
+   (license (list license:gpl2+
+                  license:expat)))) ;XFree86 1.0
 
 (define-public pciutils
   (package