[bug#34627] gnu: ocaml-menhir: Update to 20181113.

Message ID 87d0ni28fk.fsf@gmail.com
State Accepted
Headers show
Series [bug#34627] gnu: ocaml-menhir: Update to 20181113. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Gabriel Hondet Feb. 23, 2019, 8:50 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-menhir): Update to 20181113.
---
 gnu/packages/ocaml.scm | 32 +++++++++++++++++++-------------
 1 file changed, 19 insertions(+), 13 deletions(-)

Comments

Leo Famulari Feb. 26, 2019, 3:58 a.m. UTC | #1
On Sat, Feb 23, 2019 at 09:50:38AM +0100, Gabriel Hondet wrote:
> * gnu/packages/ocaml.scm (ocaml-menhir): Update to 20181113.

Thanks!

> +         (replace 'build
> +           (lambda _
> +             (invoke "make" "-f" "Makefile" "USE_OCAMLFIND=true" "all")
> +             #t))
> +         (replace 'install
> +           (lambda _
> +             (invoke "make" "-f" "Makefile" "install")
>               #t)))))

Can you add comments explaining why these phases are replaced?

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 9a807a4cb6..31e9a697a2 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -639,37 +639,43 @@  Emacs.")
 (define-public ocaml-menhir
   (package
     (name "ocaml-menhir")
-    (version "20161115")
+    (version "20181113")
     (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "http://gallium.inria.fr/~fpottier/menhir/"
-                    "menhir-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.inria.fr/fpottier/menhir.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1j8nmcj2gq6hyyi16z27amiahplgrnk4ppchpm0v4qy80kwkf47k"))))
-    (build-system gnu-build-system)
-    (inputs
-     `(("ocaml" ,ocaml)))
+                "1iqdf64ayq4s3d9jkwhs3s8wqc2s48b292hp0kcjsskfhcvwg0kr"))))
+    (build-system ocaml-build-system)
     (native-inputs
      `(("ocamlbuild" ,ocamlbuild)))
     (arguments
-     `(#:parallel-build? #f ; Parallel build causes failure
-       #:tests? #f ; No check target
+     `(#:tests? #f ; No check target
        #:phases
        (modify-phases %standard-phases
          (replace 'configure
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
                (setenv "PREFIX" out))
+             #t))
+         (replace 'build
+           (lambda _
+             (invoke "make" "-f" "Makefile" "USE_OCAMLFIND=true" "all")
+             #t))
+         (replace 'install
+           (lambda _
+             (invoke "make" "-f" "Makefile" "install")
              #t)))))
     (properties
      `((ocaml4.02-variant . ,(delay ocaml4.02-menhir))))
-    (home-page "http://gallium.inria.fr/~fpottier/menhir")
+    (home-page "http://gallium.inria.fr/~fpottier/menhir/")
     (synopsis "Parser generator")
     (description "Menhir is a parser generator.  It turns high-level grammar
 specifications, decorated with semantic actions expressed in the OCaml
-programming language into parsers, again expressed in OCaml. It is based on
+programming language into parsers, again expressed in OCaml.  It is based on
 Knuth’s LR(1) parser construction technique.")
     ;; The file src/standard.mly and all files listed in src/mnehirLib.mlpack
     ;; that have an *.ml or *.mli extension are GPL licensed. All other files