diff mbox series

bug#39192: [PATCH] gnu: hexedit: Make F1 help more reliable

Message ID 87d0b2r2wh.fsf@devup.no
State Accepted
Headers show
Series bug#39192: [PATCH] gnu: hexedit: Make F1 help more reliable | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Marius Bakke Jan. 29, 2020, 10:08 a.m. UTC
Jakub Kądziołka <kuba@kadziolka.net> writes:

> On Tue, Jan 28, 2020 at 12:36:04AM +0100, Marius Bakke wrote:
>> Jakub Kądziołka <kuba@kadziolka.net> writes:
>> 
>> > * gnu/packages/hexedit.scm (hexedit)[arguments](patch-man-path): New
>> >   phase.
>> >   [inputs]: Add MAN-DB.
>> 
>> While this change is harmless, I think we can generally expect "man" to
>> be available.  Does the program crash if man-db is not installed?  Or
>> does it print an actionable error message?
>> 
>> In the latter case I'm inclined to leave things as-is, in the former
>> case let's patch it.  But no strong opinion, mostly curious :-)
>
> Currently, the problem appears when hexedit is used in a `guix
> environment', and man-db is not specified as an input for the
> environment. In this case (assuming --pure hasn't been used), man prints
> an error message saying "no manpage for hexedit" when the user presses
> F1, but it cannot be seen until one exits hexedit. For a new user, this
> is not a trivial feat. Moreover, the error is confusing - it suggests
> that the manpage just hasn't been packaged.

Right.  The problem of manpages being unavailable unless man-db is
included in the profile is not unique to hexedit.  'git foo --help' has
the same problem in a --pure environment.  But at least then you get a
good error message.

> When man isn't found at all, no error message is printed, the F1 key
> just makes the screen blink. This could happen in a --pure environment.

I see, not great.  Sounds like a good reason to add man-db as an input
in this case.

> In hindsight, this is something I should've explained in my first message.
> Sorry about that.

No worries, these things are difficult.  :-)

Pushed in 602059e79, with a few cosmetic modifications:
diff mbox series

Patch

diff --git a/gnu/packages/hexedit.scm b/gnu/packages/hexedit.scm
index 368a902ce3..e1a029167a 100644
--- a/gnu/packages/hexedit.scm
+++ b/gnu/packages/hexedit.scm
@@ -49,20 +49,22 @@ 
      `(#:tests? #f                      ; no check target
        #:phases
        (modify-phases %standard-phases
-         ;; Make F1 open the man page even if man-db is not in the profile
+         ;; Make F1 open the man page even if man-db is not in the profile.
          (add-after 'unpack 'patch-man-path
-           (lambda _
+           (lambda* (#:key inputs outputs #:allow-other-keys)
              (substitute* "interact.c"
                (("\"man\"")
-                (string-append "\"" (assoc-ref %build-inputs "man-db") "/bin/man\""))
+                (string-append "\"" (assoc-ref inputs "man-db") "/bin/man\""))
                (("\"hexedit\"")
-                (string-append "\"" (assoc-ref %outputs "out") "/share/man/man1/hexedit.1.gz\""))))))))
+                (string-append "\"" (assoc-ref outputs "out")
+                               "/share/man/man1/hexedit.1.gz\"")))
+             #t)))))
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)))
     (inputs
-     `(("ncurses" ,ncurses)
-       ("man-db" ,man-db)))
+     `(("man-db" ,man-db)
+       ("ncurses" ,ncurses)))
     (synopsis "View and edit files or devices in hexadecimal or ASCII")
     (description "hexedit shows a file both in ASCII and in hexadecimal.  The
 file can be a device as the file is read a piece at a time.  You can modify