diff mbox series

[bug#40426] Add g-golf

Message ID 87d088z71y.fsf@gmail.com
State Accepted
Headers show
Series [bug#40426] Add g-golf | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Mike Rosset April 15, 2020, 11:02 p.m. UTC
Tobias Geerinckx-Rice via Guix-patches via writes:

>
> …‘1’ means the project has released version 1 prior to this commit, or
> at least regards this commit as part of the ‘1’ series. I didn't spot
> any version number on the home page, NEWS file, git tags, …
>
> If there is no ‘1’ release, use ‘0.0.0’.
>
> The second field (REVISION) should be ‘0’, since this is the first
> *Guix* revision of this package.  The idea is that you increment the
> revision each time you change COMMIT, so Guix knows which commit is
> newer and can ‘guix package -u’ properly.
>
> Since the 2 should be updated together, bind them together:
>
>  (let ((commit "f00")
>        (revision "0")) …


Slight change to my follow up patch, version should be 0.1.0.
diff mbox series

Patch

From 31947bce363b87b2f82e98f69704296b22a1be47 Mon Sep 17 00:00:00 2001
From: Mike Rosset <mike.rosset@gmail.com>
Date: Wed, 15 Apr 2020 09:41:10 -0700
Subject: [PATCH] gnu: g-golf: Fix version to 0.1.0-0.4a4edf2

* gnu/packages/guile-xyz.scm (g-golf): Fix version to 0.1.0-0.4a4edf2.
---
 gnu/packages/guile-xyz.scm | 17 ++++++++++-------
 1 file changed, 10 insertions(+), 7 deletions(-)

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index ebd7d89dec..f725280ce1 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1652,10 +1652,13 @@  capabilities.")
     (license license:gpl3+)))
 
 (define-public g-golf
-  (let ((commit "4a4edf25e4877df9182c77843bdd98ab59e13ef7"))
+  (let ((commit "4a4edf25e4877df9182c77843bdd98ab59e13ef7")
+        (revision "0"))
     (package
       (name "g-golf")
-      (version (git-version "1" "683" commit))
+      (version (git-version "0.1.0" revision commit))
+      ;; g-golf is still work in progress.  Since there are no release
+      ;; tarballs we use git for sources.
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
@@ -1684,13 +1687,13 @@  capabilities.")
       (arguments
        `(#:phases
          (modify-phases %standard-phases
-           (add-before 'configure 'tests-work-arounds
+           (add-before 'configure 'substitue-tty-test
              (lambda* (#:key inputs #:allow-other-keys)
                ;; In build environment, There is no /dev/tty
-               (substitute*
-                   "test-suite/tests/gobject.scm"
-                 (("/dev/tty") "/dev/null"))))
-           (add-before 'configure 'substitute-libs
+               (substitute* "test-suite/tests/gobject.scm"
+                 (("/dev/tty") "/dev/null")
+                 #t)))
+           (add-before 'configure 'substitute-libriaries
              (lambda* (#:key inputs outputs #:allow-other-keys)
                (let* ((get (lambda (key lib)
                              (string-append (assoc-ref inputs key) "/lib/" lib)))
-- 
2.26.0