diff mbox series

[bug#42881] gnu: libmicrohttpd: Update to 0.9.71.

Message ID 87d03qnu78.fsf@rohleder.de
State Accepted
Headers show
Series [bug#42881] gnu: libmicrohttpd: Update to 0.9.71. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Michael Rohleder Aug. 16, 2020, 9:42 p.m. UTC
Hey nckx,

Tobias Geerinckx-Rice 写道:
>> * gnu/packages/gnunet.scm (libmicrohttpd): Update to 0.9.71.
> This ‘patch’ release breaks dependents like ola & drawpile:

uhm yes. I tested only some dependents like faust, wget2 and gnunet.
Thank you for patchig ola.

Please find this patch for drawpile:
diff mbox series

Patch

From f75982a23ccbf2089ac413e82888c584101e9525 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Sun, 16 Aug 2020 23:13:57 +0200
Subject: [PATCH] gnu: drawpile: Build with libmicrohttpd 0.9.71.

* gnu/packages/graphics.scm (drawpile)[arguments]: Add patch phase.
---
 gnu/packages/graphics.scm | 16 +++++++++++++++-
 1 file changed, 15 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index c7fefbd57d..a5d6a8cad8 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1450,7 +1450,21 @@  Automated palette selection is supported.")
                 "08w8vad8pw4a8kkshys1kd2kjvzpj62klxxxp904rx0qazw5hl80"))))
     (build-system qt-build-system)
     (arguments
-     '(#:configure-flags (list "-DTESTS=ON" "-DTOOLS=ON" "-DKIS_TABLET=ON")))
+     '(#:configure-flags (list "-DTESTS=ON" "-DTOOLS=ON" "-DKIS_TABLET=ON")
+       #:phases
+       (modify-phases %standard-phases
+         ;; libmicrohttpd>=0.9.71 changed some results from int to MHD_Result.
+         (add-after 'unpack 'patch
+           (lambda _
+             (substitute* "src/thinsrv/webadmin/qmhttp.cpp"
+               (("^int assign_to_hash") "MHD_Result assign_to_hash")
+               (("^int access_policy") "MHD_Result access_policy")
+               (("^int iterate_post") "MHD_Result iterate_post")
+               (("^int request_handler") "MHD_Result request_handler")
+               (("int ret;") "MHD_Result ret;")
+               (("ret = MHD_queue_basic_auth_fail_response")
+                "ret = (MHD_Result) MHD_queue_basic_auth_fail_response"))
+             #t)))))
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
        ("pkg-config" ,pkg-config)))
-- 
2.28.0