diff mbox series

[bug#43551] Add package emacs-quickrun

Message ID 87d02e9edk.fsf@posteo.net
State Accepted
Headers show
Series [bug#43551] Add package emacs-quickrun | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Niklas Eklund Sept. 22, 2020, 12:37 p.m. UTC

Comments

Nicolas Goaziou Sept. 23, 2020, 7:39 p.m. UTC | #1
Hello,

Niklas Eklund <niklas.eklund@posteo.net> writes:

> Subject: [PATCH] gnu: Add emacs-quickrun.
>
> * gnu/packages/emacs-xyz.scm (emacs-quickrun): New variable.

I tweaked the synopsis and the description and applied your patch. Thank
you!

Note that adding a package definition at the end of the file is
generally not a good idea, because it is more likely to introduce
conflicts.

Regards,
diff mbox series

Patch

From 4d1c89943b0157701f66f304da24ad461db38007 Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Mon, 21 Sep 2020 12:44:55 +0200
Subject: [PATCH] gnu: Add emacs-quickrun.

* gnu/packages/emacs-xyz.scm (emacs-quickrun): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4634836b89..2c884ef3a0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -78,6 +78,7 @@ 
 ;;; Copyright © 2020 Eric Bavier <bavier@posteo.net>
 ;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
 ;;; Copyright © 2020 Peng Mei Yu <i@pengmeiyu.com>
+;;; Copyright © 2020 Niklas Eklund <niklas.eklund@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -24647,3 +24648,27 @@  publically-accessible HTTP server.")
 label references and citations in LaTeX.  It is based on RefTeX, which is
 included with Emacs.")
     (license license:gpl3+)))
+
+(define-public emacs-quickrun
+  (package
+    (name "emacs-quickrun")
+    (version "2.3.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/emacsorphanage/quickrun")
+             (commit version)))
+       (sha256
+        (base32 "0a1n2v09h0n7d9p2izflqqang4ny0b46dlqvmxvkkik4bb6f4wcz"))
+       (file-name (git-file-name name version))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/emacsorphanage/quickrun")
+    (synopsis "Run commands quickly")
+    (description
+     "This package evaluates the content of a buffer, or region and displays
+the result.  It is similar to executable-interpret, but provides more
+convenient commands.  Quickrun execute not only script languages (Perl, Ruby,
+Python etc), but also compiling languages (C, C++, Go, Java etc) and markup
+languages.")
+    (license license:gpl3+)))
-- 
2.28.0