diff mbox series

[bug#47210] Enable ogg/flac/vorbis/opus support in libsndfile

Message ID 87czvy12bf.fsf@sturm.com.au
State Accepted
Headers show
Series [bug#47210] Enable ogg/flac/vorbis/opus support in libsndfile | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Ben Sturmfels March 17, 2021, 10:50 a.m. UTC
Hi folks,

This is small update to libsndfile as part of my effort to package
MediaGoblin. Essentially, the ogg/flac/vorbis/opus support is only on if
*all four* libraries are present, and opus is currently missing.

Before applying this patch, the configure phase for libsndfile reports:

  checking for flac >= 1.3.1 ... yes
  checking for ogg >= 1.3.0 ... yes
  checking for vorbis >= 1.2.3 ... yes
  checking for vorbisenc >= 1.2.3 ... yes
  checking for opus >= 1.1 ... no           <<< LOOK HERE

  configure: WARNING: *** One or more of the external libraries (ie libflac, libogg and
  configure: WARNING: *** libvorbis) is either missing (possibly only the development
  configure: WARNING: *** headers) or is of an unsupported version.
  configure: WARNING: ***
  configure: WARNING: *** Unfortunately, for ease of maintenance, the external libs
  configure: WARNING: *** are an all or nothing affair.

  -=-=-=-=-=-=-=-=-=-= Configuration Complete =-=-=-=-=-=-=-=-=-=-=-

    Configuration summary :

      External FLAC/Ogg/Vorbis/Opus : ....... no


After this patch the libsndfile configure shows:

  checking for flac >= 1.3.1 ... yes
  checking for ogg >= 1.3.0 ... yes
  checking for vorbis >= 1.2.3 ... yes
  checking for vorbisenc >= 1.2.3 ... yes
  checking for opus >= 1.1 ... yes         <<< LOOK HERE

  -=-=-=-=-=-=-=-=-=-= Configuration Complete =-=-=-=-=-=-=-=-=-=-=-

    Configuration summary :

      External FLAC/Ogg/Vorbis/Opus : ....... yes


Regards,
Ben

Ben Sturmfels

Sturm Software Engineering
www.sturm.com.au
+61 3 9024 2467

Comments

Ben Sturmfels March 17, 2021, 11:35 a.m. UTC | #1
> Hi folks,
>
> This is small update to libsndfile as part of my effort to package
> MediaGoblin. Essentially, the ogg/flac/vorbis/opus support is only on if
> *all four* libraries are present, and opus is currently missing.

Hmm, have I broken something though? With this patch applied, my build
of libsndfile succeeds, but "sbc" seems to be failing. Or maybe I'm
doing something wrong?

$ ./pre-inst-env guix build libsndfile
$ echo $?
0
$ ./pre-inst-env guix build sbc
...
checking for SNDFILE... no
configure: error: sndfile library is required
command "/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-5.0.16/bin/bash" "./configure" "CONFIG_SHELL=/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-5.0.16/bin/bash" "SHELL=/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-5.0.16/bin/bash" "--prefix=/gnu/store/nndszkyvfg56lgjnppivnm6fjsljls97-sbc-1.5" "--enable-fast-install" "--build=x86_64-unknown-linux-gnu" failed with status 1
builder for `/gnu/store/kbxzfb9lc9wp69q9p5zfcclxpd16jyj0-sbc-1.5.drv' failed with exit code 1
build of /gnu/store/kbxzfb9lc9wp69q9p5zfcclxpd16jyj0-sbc-1.5.drv failed
View build log at '/var/log/guix/drvs/kb/xzfb9lc9wp69q9p5zfcclxpd16jyj0-sbc-1.5.drv.bz2'.
guix build: error: build of `/gnu/store/kbxzfb9lc9wp69q9p5zfcclxpd16jyj0-sbc-1.5.drv' failed
diff mbox series

Patch

From d91cedcdd324d10d0406166c43b938cba842eb03 Mon Sep 17 00:00:00 2001
From: Ben Sturmfels <ben@sturm.com.au>
Date: Wed, 17 Mar 2021 21:35:16 +1100
Subject: [PATCH] gnu: libsndfile: enable vorbis/ogg/flac/opus support.

* gnu/packages/pulseaudio.scm (libsndfile): Add input for opus to trigger
all-or-nothing external library support
---
 gnu/packages/pulseaudio.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index ea61dd807c..0c1acdc6e0 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -102,7 +102,8 @@ 
     (inputs
      `(("libvorbis" ,libvorbis)
        ("libogg" ,libogg)
-       ("flac" ,flac)))
+       ("flac" ,flac)
+       ("opus" ,opus)))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("python" ,python)))
-- 
2.30.2