diff mbox

[bug#50208,v2,0/5] Fixes and improvements for home-services

Message ID 87czpv8bw5.fsf@trop.in
State Accepted
Headers show

Commit Message

Andrew Tropin Aug. 30, 2021, 10:28 a.m. UTC
Changes since v1:
Added missing import to xdg via a separate commit.
Added trailing dots to commit messages.

Andrew Tropin (5):
  home-services: Add utils module.
  home-services: symlink-manager: Properly handle 1st generation case.
  home-services: activation: Add support for multiline env vars.
  gnu: home: Add doc comment about the module.
  home-services: xdg: Add missing import.

 gnu/home-services.scm                 |  4 +-
 gnu/home-services/shells.scm          |  1 +
 gnu/home-services/symlink-manager.scm |  2 +-
 gnu/home-services/utils.scm           | 77 +++++++++++++++++++++++++++
 gnu/home-services/xdg.scm             |  1 +
 gnu/home.scm                          |  8 +++
 6 files changed, 90 insertions(+), 3 deletions(-)
 create mode 100644 gnu/home-services/utils.scm

Comments

Oleg Pykhalov Aug. 30, 2021, 11:19 p.m. UTC | #1
Andrew Tropin <andrew@trop.in> writes:

> Changes since v1:
> Added missing import to xdg via a separate commit.
> Added trailing dots to commit messages.
>
> Andrew Tropin (5):
>   home-services: Add utils module.
>   home-services: symlink-manager: Properly handle 1st generation case.
>   home-services: activation: Add support for multiline env vars.
>   gnu: home: Add doc comment about the module.
>   home-services: xdg: Add missing import.
>
>  gnu/home-services.scm                 |  4 +-
>  gnu/home-services/shells.scm          |  1 +
>  gnu/home-services/symlink-manager.scm |  2 +-
>  gnu/home-services/utils.scm           | 77 +++++++++++++++++++++++++++
>  gnu/home-services/xdg.scm             |  1 +
>  gnu/home.scm                          |  8 +++
>  6 files changed, 90 insertions(+), 3 deletions(-)
>  create mode 100644 gnu/home-services/utils.scm
>
> -- 
> 2.33.0

[…]

Tabified local.mk, pushed to wip-guix-home.

Oleg.
Andrew Tropin Aug. 31, 2021, 7:03 a.m. UTC | #2
On 2021-08-31 02:19, Oleg Pykhalov wrote:

> Andrew Tropin <andrew@trop.in> writes:
>
>> Changes since v1:
>> Added missing import to xdg via a separate commit.
>> Added trailing dots to commit messages.
>>
>> Andrew Tropin (5):
>>   home-services: Add utils module.
>>   home-services: symlink-manager: Properly handle 1st generation case.
>>   home-services: activation: Add support for multiline env vars.
>>   gnu: home: Add doc comment about the module.
>>   home-services: xdg: Add missing import.
>>
>>  gnu/home-services.scm                 |  4 +-
>>  gnu/home-services/shells.scm          |  1 +
>>  gnu/home-services/symlink-manager.scm |  2 +-
>>  gnu/home-services/utils.scm           | 77 +++++++++++++++++++++++++++
>>  gnu/home-services/xdg.scm             |  1 +
>>  gnu/home.scm                          |  8 +++
>>  6 files changed, 90 insertions(+), 3 deletions(-)
>>  create mode 100644 gnu/home-services/utils.scm
>>
>> -- 
>> 2.33.0
>
> […]
>
> Tabified local.mk, pushed to wip-guix-home.
>
> Oleg.

It seems we are finished with basic home-services, refactoring and
preparing CLI now, will send it in a separate thread.

Thank you very much!)
diff mbox

Patch

From 2c7a295468aecd4f40e98ac0651800f561d89a71 Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Mon, 30 Aug 2021 13:22:16 +0300
Subject: [PATCH v2 5/5] home-services: xdg: Add missing import.

---
 gnu/home-services/xdg.scm | 1 +
 1 file changed, 1 insertion(+)

diff --git a/gnu/home-services/xdg.scm b/gnu/home-services/xdg.scm
index 6e4a2542a3..535c8667a1 100644
--- a/gnu/home-services/xdg.scm
+++ b/gnu/home-services/xdg.scm
@@ -26,6 +26,7 @@ 
   #:use-module (guix gexp)
   #:use-module (guix records)
   #:use-module (guix i18n)
+  #:use-module (guix diagnostics)
 
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1)
-- 
2.33.0