diff mbox series

[bug#53148] gnu: java-snakeyaml: Fix the source URI

Message ID 87czl0ljgu.fsf@gmail.com
State New
Headers show
Series [bug#53148] gnu: java-snakeyaml: Fix the source URI | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Artyom V. Poptsov Jan. 9, 2022, 8:53 p.m. UTC
Hello,

I found that BitBucket redirects to the login page:

--8<---------------cut here---------------start------------->8---
$ ./pre-inst-env guix build --no-substitutes java-snakeyaml
[...]
Starting download of /gnu/store/j4isfqwkfx1c8nhr3jry0rkdq8r39ckc-java-snakeyaml-1.18.tar.gz
From https://bitbucket.org/asomov/snakeyaml/get/v1.18.tar.gz...
following redirection to `https://bitbucket.org/account/signin/?next=/asomov/snakeyaml/get/v1.18.tar.gz'...
following redirection to `https://id.atlassian.com/login?application=bitbucket&continue=https%3A%2F%2Fbitbucket.org%2Faccount%2Fsignin%2F%3FredirectCount%3D1%26next%3D%252Fasomov%252Fsnakeyaml%252Fget%252Fv1.18.tar.gz'...
downloading from https://bitbucket.org/asomov/snakeyaml/get/v1.18.tar.gz ...

sha256 hash mismatch for /gnu/store/j4isfqwkfx1c8nhr3jry0rkdq8r39ckc-java-snakeyaml-1.18.tar.gz:
  expected hash: 0474cqcv46zgv9bhms2vgawakq1vyj0hp3h3f1bfys46msia90bh
  actual hash:   11x0dw0l9a7kj55qzr8hzc0fzh44xwwpcjarik10wxyg446wra1j
hash mismatch for store item '/gnu/store/j4isfqwkfx1c8nhr3jry0rkdq8r39ckc-java-snakeyaml-1.18.tar.gz'
build of /gnu/store/f5h57jakhnray2iivbviih8hhyr8far8-java-snakeyaml-1.18.tar.gz.drv failed
View build log at '/var/log/guix/drvs/f5/h57jakhnray2iivbviih8hhyr8far8-java-snakeyaml-1.18.tar.gz.drv.bz2'.
cannot build derivation `/gnu/store/da59l9m79qxqqlhp7z9r7yvh4ysdvgpg-java-snakeyaml-1.18.drv': 1 dependencies couldn't be built
guix build: error: build of `/gnu/store/da59l9m79qxqqlhp7z9r7yvh4ysdvgpg-java-snakeyaml-1.18.drv' failed
--8<---------------cut here---------------end--------------->8---

So I replaced the BitBucket URI with GitHub mirror URI.

'guix lint' complains about the lack of upstream releases because
there's no git tags for each release. It's really unfortunate situation
but that's how the project's upstream is organized.  :-/

Thanks,

- Artyom

Comments

M Jan. 9, 2022, 8:57 p.m. UTC | #1
Artyom V. Poptsov schreef op zo 09-01-2022 om 23:53 [+0300]:
> -              (uri (string-append
> "https://bitbucket.org/asomov/snakeyaml/get/v"
> +              (uri (string-append
> "https://github.com/snakeyaml/snakeyaml"
>                                    version ".tar.gz"))

When I visit
 https://github.com/snakeyaml/snakeyaml1.18.tar.gz

I get a 404. Are you sure about the URI?
diff mbox series

Patch

From 40b56fbd66226f891e36a5114993660676065b36 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 9 Jan 2022 23:20:35 +0300
Subject: [PATCH] gnu: java-snakeyaml: Fix the source URI

* gnu/packages/java.scm (java-snakeyaml): Use the GitHub mirror instead of
  BitBucket repository as BitBucket redirects to the login page.
---
 gnu/packages/java.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index e54d2ed0cb..b091ca8874 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -9917,7 +9917,7 @@  of deserialization.")
     (version "1.18")
     (source (origin
               (method url-fetch)
-              (uri (string-append "https://bitbucket.org/asomov/snakeyaml/get/v"
+              (uri (string-append "https://github.com/snakeyaml/snakeyaml"
                                   version ".tar.gz"))
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
-- 
2.25.1